aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 19c48e6..b742893 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -8,6 +8,10 @@ authors = [
"Jonathan Weth <dev@jonathanweth.de>"
]
license = "GPL-2.0-or-later"
+packages = [
+ { include = "rwa/" },
+]
+include = ["README.rst", "LICENCE", "org.ArcticaProject.RWASupportSessionService.service", "docs/*", "docs/*/**"]
[tool.poetry.dependencies]
python = "^3.7"
@@ -25,6 +29,12 @@ dynaconf = "^3.0.0"
sphinx = "^3.0"
sphinx-autodoc-typehints = "^1.7"
+[tool.poetry.scripts]
+rwa-support-sessionservice = 'rwa.support.sessionservice.service:main'
+
+[tool.black]
+line-length = 100
+
[build-system]
requires = ["poetry>=0.12"]
build-backend = "poetry.masonry.api"