aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-05-07 17:18:10 -0700
committerCharles Kerr <charles.kerr@canonical.com>2012-05-07 17:18:10 -0700
commit84a63033c820bf890e0bcecd2f07cc325c44e9e9 (patch)
tree64bc31aaac19f8c5785b851f3b07541d91d36a8c /configure.ac
parent78c634c4ff2d9f64712f4a667facc66dc48a9762 (diff)
downloadayatana-ido-84a63033c820bf890e0bcecd2f07cc325c44e9e9.tar.gz
ayatana-ido-84a63033c820bf890e0bcecd2f07cc325c44e9e9.tar.bz2
ayatana-ido-84a63033c820bf890e0bcecd2f07cc325c44e9e9.zip
require gtk3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 1 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 6e350b9..8b69cca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,19 +78,7 @@ AC_FUNC_MALLOC
AC_FUNC_MMAP
AC_CHECK_FUNCS([memset munmap strcasecmp strdup])
-AC_ARG_WITH([gtk],
- [AS_HELP_STRING([--with-gtk],
- [Which version of gtk to use @<:@default=3@:>@])],
- [],
- [with_gtk=3])
-AM_CONDITIONAL(USE_GTK3, [test "x$with_gtk" = x3])
-
-if test "x$with_gtk" = "x2"; then
- PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.19.7)
-else
- PKG_CHECK_MODULES(GTK, gtk+-3.0 >= 3.0.0)
- AC_DEFINE_UNQUOTED(USE_GTK3, , [Use GTK3])
-fi
+PKG_CHECK_MODULES(GTK, gtk+-3.0 >= 3.0.0)
AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)
@@ -157,7 +145,6 @@ echo " ido $VERSION"
echo " ==============================="
echo ""
echo " Prefix : ${prefix}"
-echo " GTK : ${with_gtk}"
echo " gcov : ${use_gcov}"
echo ""
echo " Documentation: ${enable_gtk_doc}"