aboutsummaryrefslogtreecommitdiff
path: root/example/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-06-21 11:32:46 -0500
committerTed Gould <ted@gould.cx>2011-06-21 11:32:46 -0500
commite1c47927f737e8c018f800a47315b5c03f02f08c (patch)
treea745cf8fbfce7fc1fb4bd62c67b9440527573337 /example/Makefile.am
parent33ab93de41a2e6985661d79788873fb774e624b5 (diff)
parentd61ddbef2c5f207e5ba70c976b8565a043c646ca (diff)
downloadayatana-ido-e1c47927f737e8c018f800a47315b5c03f02f08c.tar.gz
ayatana-ido-e1c47927f737e8c018f800a47315b5c03f02f08c.tar.bz2
ayatana-ido-e1c47927f737e8c018f800a47315b5c03f02f08c.zip
Updating to GTK3
Diffstat (limited to 'example/Makefile.am')
-rw-r--r--example/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/example/Makefile.am b/example/Makefile.am
index 7e76434..b986b9b 100644
--- a/example/Makefile.am
+++ b/example/Makefile.am
@@ -1,3 +1,9 @@
+if USE_GTK3
+VER=3
+else
+VER=
+endif
+
noinst_PROGRAMS = \
messagedialog \
menus
@@ -24,6 +30,6 @@ menus_CPPFLAGS = \
$(GTK_CFLAGS) \
$(MAINTAINER_CFLAGS)
-messagedialog_LDADD = $(top_builddir)/src/libido-0.1.la $(GTK_LIBS)
+messagedialog_LDADD = $(top_builddir)/src/libido$(VER)-0.1.la $(GTK_LIBS)
-menus_LDADD = $(top_builddir)/src/libido-0.1.la $(GTK_LIBS)
+menus_LDADD = $(top_builddir)/src/libido$(VER)-0.1.la $(GTK_LIBS)