aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b039352..70b509f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,6 +51,15 @@ if (ENABLE_TESTS)
enable_testing()
add_subdirectory(example)
add_subdirectory(tests)
+ # coverage
+ if (ENABLE_COVERAGE)
+ find_package(CoverageReport)
+ ENABLE_COVERAGE_REPORT(
+ TARGETS "ayatana-ido3-0.4"
+ TESTS "gtest-menuitems"
+ FILTER /usr/include ${CMAKE_BINARY_DIR}/*
+ )
+ endif()
endif()
# Display config info