aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b56a9de..32232ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,6 +117,16 @@ AS_IF([test "x$enable_maintainer_flags" = "xyes" && test "x$GCC" = "xyes"],
AC_SUBST(MAINTAINER_CFLAGS)
+dnl = gcov Coverage Reporting =================================================
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AM_CONDITIONAL([HAVE_GCOV], [test "x$ac_cv_check_gcov" = xyes])
+AM_CONDITIONAL([HAVE_LCOV], [test "x$ac_cv_check_lcov" = xyes])
+AM_CONDITIONAL([HAVE_GCOVR], [test "x$ac_cv_check_gcovr" = xyes])
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
dnl = GTK Doc Check ===========================================================
@@ -140,6 +150,7 @@ echo " ==============================="
echo ""
echo " Prefix : ${prefix}"
echo " GTK : ${with_gtk}"
+echo " gcov : ${use_gcov}"
echo ""
echo " Documentation: ${enable_gtk_doc}"
echo ""