aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 89b9b5b..39ad2d3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -45,3 +45,25 @@ gtest_menuitems_LDADD = \
$(IDOLIB) \
libgtest.a
+#############################
+# Dialog tests
+#############################
+
+TESTS += gtest-dialog
+check_PROGRAMS += gtest-dialog
+
+gtest_dialog_SOURCES = \
+ gtest-dialog.cpp
+gtest_dialog_CPPFLAGS = \
+ $(GCC_CFLAGS) \
+ $(GTK_CFLAGS) \
+ $(MAINTAINER_CFLAGS) \
+ $(AM_CPPFLAGS)
+gtest_dialog_LDFLAGS = \
+ -pthread
+gtest_dialog_LDADD = \
+ $(GTK_LIBS) \
+ $(IDOLIB) \
+ libgtest.a
+
+