aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-02-17 16:42:41 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-02-17 16:42:41 +0100
commit0ef4fc107ac7a9bc0ea6418076be8510eb862ecc (patch)
treed525d03275c657c9187ca126485bf4285de77dc9 /CMakeLists.txt
parent3bbc1d0c2b8a54a940ef78300748074f3bf8f0d7 (diff)
parentef11732b871d63d70d58e4d397d8a4c42e81ab0c (diff)
downloadayatana-indicator-application-0ef4fc107ac7a9bc0ea6418076be8510eb862ecc.tar.gz
ayatana-indicator-application-0ef4fc107ac7a9bc0ea6418076be8510eb862ecc.tar.bz2
ayatana-indicator-application-0ef4fc107ac7a9bc0ea6418076be8510eb862ecc.zip
Merge branch 'tari01-pr/cleanup-compile-flags'
Attributes GH PR #23: https://github.com/AyatanaIndicators/ayatana-indicator-application/pull/23
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 7 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 06b10a3..09f6d22 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,8 +19,13 @@ else()
endif()
if(ENABLE_WERROR)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
+ add_definitions("-Werror")
+endif()
+
+if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ add_definitions("-Weverything")
+else()
+ add_definitions("-Wall")
endif()
# Check for prerequisites
@@ -35,18 +40,6 @@ include(GNUInstallDirs)
set(PROJECT_VERSION "0.8.91")
set(PROJECT_NAME "ayatana-indicator-application")
-if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
-
- set(COMPILE_FLAGS "${COMPILE_FLAGS} -Weverything")
- set(COMPILE_FLAGS "${COMPILE_FLAGS} -Wno-c++98-compat -Wno-padded")
- set(COMPILE_FLAGS "${COMPILE_FLAGS} -Wno-documentation")
-
-else()
-
- set(COMPILE_FLAGS "${COMPILE_FLAGS} -Wall")
-
-endif()
-
# Make everything
add_subdirectory(data)