aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-16 12:20:43 -0500
committerTed Gould <ted@canonical.com>2009-10-16 12:20:43 -0500
commit664bc74b6f0b3eb6ca30539628e2350ed3a2e20c (patch)
treec04625cef42f15f8b66cac9855596c8577d33dd4 /Makefile.am
parente265e46176c6c8633849b3a5d65b7f86bda47318 (diff)
parentafd1d1747e91db94c370ea4a3400906fe4227e09 (diff)
downloadayatana-indicator-application-664bc74b6f0b3eb6ca30539628e2350ed3a2e20c.tar.gz
ayatana-indicator-application-664bc74b6f0b3eb6ca30539628e2350ed3a2e20c.tar.bz2
ayatana-indicator-application-664bc74b6f0b3eb6ca30539628e2350ed3a2e20c.zip
Adding in the DBus interface files and building of those.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1d1ff09..fb738a5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,3 +2,17 @@ SUBDIRS = data \
src
DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall
+
+dist-hook:
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --gnu-changelog ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || (rm -f ChangeLog.tmp; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo Failed to generate ChangeLog: not a branch >&2; \
+ fi