aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-12-08 15:06:07 -0600
committerTed Gould <ted@gould.cx>2009-12-08 15:06:07 -0600
commit4a19cb469fdbdbe9b7355fc9fdf44368fa9c9b6b (patch)
treebc930efbeb86c7bcd986e2d6eb75f0a3ad6fee91 /Makefile.am
parentbfb9e7775ff9a688690558cade7e2778e56a1f3c (diff)
parentcf4dd4a9e3f1a2d514f7b6ddb5cb0763411b6961 (diff)
downloadayatana-indicator-application-4a19cb469fdbdbe9b7355fc9fdf44368fa9c9b6b.tar.gz
ayatana-indicator-application-4a19cb469fdbdbe9b7355fc9fdf44368fa9c9b6b.tar.bz2
ayatana-indicator-application-4a19cb469fdbdbe9b7355fc9fdf44368fa9c9b6b.zip
Adding support for building gtk-doc documentation.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 33f9f3e..d63fda6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,15 @@
-SUBDIRS = data \
- src \
- example \
- tests
+SUBDIRS = data \
+ src \
+ example \
+ tests \
+ docs
-DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall
+EXTRA_DIST = \
+ gtk-doc.make \
+ omf.make \
+ xmldocs.make
+
+DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-localinstall
dist-hook:
@if test -d "$(top_srcdir)/.bzr"; \