aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-09-15 17:16:00 -0500
committerTed Gould <ted@gould.cx>2010-09-15 17:16:00 -0500
commitc2aee8ac8876b03c1fcddaeca884620f973d698d (patch)
treed3f8ae528c9a960553fc0ca6499891f7415e7381 /Makefile.am
parenta4dc11aaecfcb3b51b427394c6fc3ba59fdae402 (diff)
downloadayatana-indicator-application-c2aee8ac8876b03c1fcddaeca884620f973d698d.tar.gz
ayatana-indicator-application-c2aee8ac8876b03c1fcddaeca884620f973d698d.tar.bz2
ayatana-indicator-application-c2aee8ac8876b03c1fcddaeca884620f973d698d.zip
Adding a disthook for AUTHORS
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ba772b0..98e4a88 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,3 +30,15 @@ dist-hook:
else \
echo Failed to generate ChangeLog: not a branch >&2; \
fi
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating AUTHORS && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --long --levels=0 | grep -e "^\s*author:" -e "^\s*committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
+ && mv -f AUTHORS.tmp $(top_distdir)/AUTHORS \
+ || (rm -f AUTHORS.tmp; \
+ echo Failed to generate AUTHORS >&2 ); \
+ else \
+ echo Failed to generate AUTHORS: not a branch >&2; \
+ fi