aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-15 14:45:07 -0500
committerTed Gould <ted@canonical.com>2009-10-15 14:45:07 -0500
commitd6fb194d49ea59b14b673fa4460a40207113a718 (patch)
tree3b26cdcd9366540aa4a5fcce795eae7e8b3704e3 /Makefile.am
parentdf1cc80c7f1ac98fd298631c7555663dd144df73 (diff)
downloadayatana-indicator-application-d6fb194d49ea59b14b673fa4460a40207113a718.tar.gz
ayatana-indicator-application-d6fb194d49ea59b14b673fa4460a40207113a718.tar.bz2
ayatana-indicator-application-d6fb194d49ea59b14b673fa4460a40207113a718.zip
Building the ChangeLog on dist
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1d1ff09..fb738a5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,3 +2,17 @@ SUBDIRS = data \
src
DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall
+
+dist-hook:
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --gnu-changelog ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || (rm -f ChangeLog.tmp; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo Failed to generate ChangeLog: not a branch >&2; \
+ fi