aboutsummaryrefslogtreecommitdiff
path: root/bindings/mono/Makefile.am
diff options
context:
space:
mode:
authorSense Egbert Hofstede <sense@ubuntu.com>2010-09-20 17:54:51 +0200
committerSense Egbert Hofstede <sense@ubuntu.com>2010-09-20 17:54:51 +0200
commit482276fcb7af568bf09047d9613e6817c4af8ad1 (patch)
tree0b0c6ff946e998a15a459800acd73a1ac82c9293 /bindings/mono/Makefile.am
parent6c8da9ed8f79fb5f411a4130c99ce3189b7b5b82 (diff)
parent316dbc5d675e78b92334dc087d95c795a3a108d0 (diff)
downloadayatana-indicator-application-482276fcb7af568bf09047d9613e6817c4af8ad1.tar.gz
ayatana-indicator-application-482276fcb7af568bf09047d9613e6817c4af8ad1.tar.bz2
ayatana-indicator-application-482276fcb7af568bf09047d9613e6817c4af8ad1.zip
Merging Jo Shields' fixes to the build infrastructure to shut GAPI up.
Diffstat (limited to 'bindings/mono/Makefile.am')
-rw-r--r--bindings/mono/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/bindings/mono/Makefile.am b/bindings/mono/Makefile.am
index 203dcae..d9c0ef6 100644
--- a/bindings/mono/Makefile.am
+++ b/bindings/mono/Makefile.am
@@ -15,6 +15,8 @@ ASSEMBLY = $(ASSEMBLY_NAME).dll
POLICY = policy.$(POLICY_VERSION).$(ASSEMBLY_NAME)
POLICY_VERSION = 0.0
DLLPOLICY = $(POLICY).dll
+WRAPPER_FREE_BINDING_SRC = ../../src/app-indicator.c
+WRAPPER_FREE_BINDING = app-indicator.c
TARGET = \
$(ASSEMBLY) \
@@ -35,6 +37,7 @@ CLEANFILES = \
$(RAW_API) \
$(TEST) \
$(DLLPOLICY) \
+ $(WRAPPER_FREE_BINDING) \
$(POLICY).config
DISTCLEANFILES = $(ASSEMBLY).config
@@ -57,9 +60,12 @@ GACUTIL_FLAGS=-package $(ASSEMBLY_NAME) -root $(DESTDIR)$(prefix)/lib
references = $(GTK_SHARP_LIBS)
test_references = $(GTK_SHARP_LIBS) $(NUNIT_LIBS) -r:$(ASSEMBLY)
-$(RAW_API): app-indicator.sources.xml
+$(RAW_API): app-indicator.sources.xml $(WRAPPER_FREE_BINDING)
$(GAPI_PARSER) app-indicator.sources.xml
+$(WRAPPER_FREE_BINDING): $(WRAPPER_FREE_BINDING_SRC)
+ sed '/signals\[X_NEW_LABEL\] /,+6d' $(WRAPPER_FREE_BINDING_SRC) > $(WRAPPER_FREE_BINDING)
+
$(MIDDLE_API): $(METADATA) $(RAW_API)
cp $(srcdir)/$(RAW_API) $(MIDDLE_API)
chmod u+w $(MIDDLE_API)