aboutsummaryrefslogtreecommitdiff
path: root/bindings/mono/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-06-01 10:58:57 -0500
committerTed Gould <ted@gould.cx>2010-06-01 10:58:57 -0500
commite0ddc2dbf98ad7411b9a29b34bfd99f94f1ce74e (patch)
tree7d385aef35dea7ba3fab4798b9c008eede3732f2 /bindings/mono/Makefile.am
parentf7fd52b7477bfbef0762e8e608f3a9b095133fd1 (diff)
parent01fafa492912486a291d70d2289ba4d77355be92 (diff)
downloadayatana-indicator-application-e0ddc2dbf98ad7411b9a29b34bfd99f94f1ce74e.tar.gz
ayatana-indicator-application-e0ddc2dbf98ad7411b9a29b34bfd99f94f1ce74e.tar.bz2
ayatana-indicator-application-e0ddc2dbf98ad7411b9a29b34bfd99f94f1ce74e.zip
Fixes to docuementation and making the enums build correctly with gtk-mkenum
Diffstat (limited to 'bindings/mono/Makefile.am')
-rw-r--r--bindings/mono/Makefile.am12
1 files changed, 2 insertions, 10 deletions
diff --git a/bindings/mono/Makefile.am b/bindings/mono/Makefile.am
index 7e2b0d2..4d2d8b4 100644
--- a/bindings/mono/Makefile.am
+++ b/bindings/mono/Makefile.am
@@ -12,7 +12,7 @@ METADATA = libappindicator-api.metadata
ASSEMBLY_NAME = appindicator-sharp
ASSEMBLY = appindicator-sharp.dll
TARGET = $(ASSEMBLY) $(ASSEMBLY).config
-assemblydir = $(libdir)/appindicator-sharp-0.1
+assemblydir = $(libdir)/cli/appindicator-sharp-0.1
assembly_DATA = $(TARGET)
CLEANFILES = $(ASSEMBLY) $(ASSEMBLY).mdb generated-stamp generated/*.cs $(API) $(MIDDLE_API) $(RAW_API) $(TEST)
DISTCLEANFILES = $(ASSEMBLY).config
@@ -46,21 +46,13 @@ $(MIDDLE_API): $(METADATA) $(RAW_API)
fi
$(API): $(MIDDLE_API) Makefile.am
- sed -e "s|PROP_ID_S|ID|" \
- -e "s|PROP_ID_S|id|" \
- -e "s|PROP_STATUS_S|Status|" \
+ sed -e "s|PROP_ID_S|id|" \
-e "s|PROP_STATUS_S|status|" \
- -e "s|PROP_CATEGORY_S|Category|" \
-e "s|PROP_CATEGORY_S|category|" \
- -e "s|PROP_ICON_NAME_S|IconName|" \
-e "s|PROP_ICON_NAME_S|icon-name|" \
- -e "s|PROP_ATTENTION_ICON_NAME_S|AttentionIconName|" \
-e "s|PROP_ATTENTION_ICON_NAME_S|attention-icon-name|" \
- -e "s|PROP_ICON_THEME_PATH_S|IconThemePath|" \
-e "s|PROP_ICON_THEME_PATH_S|icon-theme-path|" \
- -e "s|PROP_MENU_S|Menu|" \
-e "s|PROP_MENU_S|menu|" \
- -e "s|PROP_CONNECTED_S|Connected|" \
-e "s|PROP_CONNECTED_S|connected|" \
$< > $@