aboutsummaryrefslogtreecommitdiff
path: root/bindings/mono/examples/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-12-14 09:42:57 -0600
committerTed Gould <ted@gould.cx>2009-12-14 09:42:57 -0600
commitaebb91e11ed149e1f48e9f05e3d4680304f42620 (patch)
tree27ca1a00c4bb7cc491393b13902430b94c578daa /bindings/mono/examples/Makefile.am
parentd3038937c5f5621da42952a026c61e1f5f74e83a (diff)
parent5e6e5ba6c2ad9b2919aa87da80cbbe8f4655d1c1 (diff)
downloadayatana-indicator-application-aebb91e11ed149e1f48e9f05e3d4680304f42620.tar.gz
ayatana-indicator-application-aebb91e11ed149e1f48e9f05e3d4680304f42620.tar.bz2
ayatana-indicator-application-aebb91e11ed149e1f48e9f05e3d4680304f42620.zip
Merging in Jason's fix of Cody's branch. Yeah, seriously.
Diffstat (limited to 'bindings/mono/examples/Makefile.am')
-rw-r--r--bindings/mono/examples/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/bindings/mono/examples/Makefile.am b/bindings/mono/examples/Makefile.am
new file mode 100644
index 0000000..cb7f268
--- /dev/null
+++ b/bindings/mono/examples/Makefile.am
@@ -0,0 +1,12 @@
+ASSEMBLY = IndicatorExample.exe
+CSFILES = IndicatorExample.cs
+CLEANFILES = $(ASSEMBLY)
+
+EXTRA_DIST = $(CSFILES)
+
+references = $(GTK_SHARP_LIBS) -r:$(top_builddir)/bindings/mono/appindicator-sharp.dll
+
+$(ASSEMBLY):
+ $(CSC) $(CSFLAGS) -out:$(ASSEMBLY) -target:exe $(references) $(CSFILES)
+
+all: $(ASSEMBLY) \ No newline at end of file