aboutsummaryrefslogtreecommitdiff
path: root/bindings/mono/examples/Makefile.am
diff options
context:
space:
mode:
authorCody Russell <crussell@canonical.com>2009-12-12 12:20:52 -0600
committerCody Russell <crussell@canonical.com>2009-12-12 12:20:52 -0600
commit59526b689303cde25721d0a1fdcafdb371fdddba (patch)
treeee7a1bde4ce2e89942fa8bc2b3e3515143a264eb /bindings/mono/examples/Makefile.am
parented4810839b0bd16af47201bae84524088b9ef178 (diff)
downloadayatana-indicator-application-59526b689303cde25721d0a1fdcafdb371fdddba.tar.gz
ayatana-indicator-application-59526b689303cde25721d0a1fdcafdb371fdddba.tar.bz2
ayatana-indicator-application-59526b689303cde25721d0a1fdcafdb371fdddba.zip
Initial stab at setting up test/example fu
Diffstat (limited to 'bindings/mono/examples/Makefile.am')
-rw-r--r--bindings/mono/examples/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/bindings/mono/examples/Makefile.am b/bindings/mono/examples/Makefile.am
new file mode 100644
index 0000000..cb7f268
--- /dev/null
+++ b/bindings/mono/examples/Makefile.am
@@ -0,0 +1,12 @@
+ASSEMBLY = IndicatorExample.exe
+CSFILES = IndicatorExample.cs
+CLEANFILES = $(ASSEMBLY)
+
+EXTRA_DIST = $(CSFILES)
+
+references = $(GTK_SHARP_LIBS) -r:$(top_builddir)/bindings/mono/appindicator-sharp.dll
+
+$(ASSEMBLY):
+ $(CSC) $(CSFLAGS) -out:$(ASSEMBLY) -target:exe $(references) $(CSFILES)
+
+all: $(ASSEMBLY) \ No newline at end of file