aboutsummaryrefslogtreecommitdiff
path: root/bindings/python/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-12-17 00:08:42 -0600
committerTed Gould <ted@gould.cx>2009-12-17 00:08:42 -0600
commit97f6e62d618747a03ba44486f70a2230af5177fd (patch)
tree89c8aebd9d1d147c07bf6c1cedd8ddd583e5a0be /bindings/python/Makefile.am
parent985c449e8efe4e258d286857f6a71a7726b43561 (diff)
parent8a26b8c15e726e090f7cab7afd366f764f2ab73c (diff)
downloadayatana-indicator-application-97f6e62d618747a03ba44486f70a2230af5177fd.tar.gz
ayatana-indicator-application-97f6e62d618747a03ba44486f70a2230af5177fd.tar.bz2
ayatana-indicator-application-97f6e62d618747a03ba44486f70a2230af5177fd.zip
Mono and Pythong bindings living together.
Diffstat (limited to 'bindings/python/Makefile.am')
-rw-r--r--bindings/python/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/bindings/python/Makefile.am b/bindings/python/Makefile.am
new file mode 100644
index 0000000..0b606db
--- /dev/null
+++ b/bindings/python/Makefile.am
@@ -0,0 +1,40 @@
+defsdir = $(datadir)/pygtk/2.0/defs
+defs_DATA = appindicator.defs
+
+#CFLAGS = -Wall -Werror
+INCLUDES = \
+ -I$(top_srcdir)/src \
+ -DG_LOG_DOMAIN=\"appindicator-python\" \
+ -DDATADIR=\"$(datadir)\" \
+ -DLIBDIR=\"$(libdir)\" \
+ $(APPINDICATOR_PYTHON_CFLAGS) \
+ $(PYTHON_INCLUDES)
+
+pkgpythondir = $(pyexecdir)
+pkgpyexecdir = $(pyexecdir)
+
+pkgappindicatordir = $(pkgpythondir)/appindicator
+pkgappindicator_PYTHON = __init__.py
+
+appindicatordir = $(pkgpyexecdir)/appindicator
+appindicator_LTLIBRARIES = _appindicator.la
+
+_appindicator_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_appindicator -lpyglib-2.0-python2.6
+_appindicator_la_LIBADD = $(APPINDICATOR_PYTHON_LIBS) -L$(top_builddir)/src/.libs -lappindicator
+_appindicator_la_SOURCES = appindicatormodule.c
+nodist__appindicator_la_SOURCES = appindicator.c
+
+CLEANFILES = appindicator.c
+EXTRA_DIST = appindicator.override appindicator-arg-types.py $(defs_DATA)
+appindicator.c: $(defs_DATA) appindicator.override
+
+%.c: %.defs
+ (cd $(srcdir) \
+ && $(PYGTK_CODEGEN) \
+ --register $(PYGTK_DEFSDIR)/gtk-types.defs \
+ --register $(PYGTK_DEFSDIR)/gdk-types.defs \
+ --load-types appindicator-arg-types.py \
+ --override $*.override \
+ --prefix py$* $*.defs) > gen-$*.c \
+ && cp gen-$*.c $*.c \
+ && rm -f gen-$*.c