aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-13 13:48:46 -0500
committerTed Gould <ted@canonical.com>2009-10-13 13:48:46 -0500
commit8f6b6e08102c61b11edacd8fb01210d3f3a541a5 (patch)
treed33f055fd5102bea4308bdce40b3a7c2c7d67ac6 /configure.ac
parent140fda5adff2a21f9c158c941456d9e1f5765832 (diff)
downloadayatana-indicator-application-8f6b6e08102c61b11edacd8fb01210d3f3a541a5.tar.gz
ayatana-indicator-application-8f6b6e08102c61b11edacd8fb01210d3f3a541a5.tar.bz2
ayatana-indicator-application-8f6b6e08102c61b11edacd8fb01210d3f3a541a5.zip
Very basic.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac90
1 files changed, 90 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..fa9f69c
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,90 @@
+
+AC_INIT(indicator-custom, 0.0.1, ted@canonical.com)
+AC_COPYRIGHT([Copyright 2009 Canonical])
+
+AC_PREREQ(2.53)
+
+AM_CONFIG_HEADER(config.h)
+AM_INIT_AUTOMAKE(indicator-custom, 0.2.6)
+
+AM_MAINTAINER_MODE
+
+AC_ISC_POSIX
+AC_PROG_CC
+AM_PROG_CC_C_O
+AC_STDC_HEADERS
+AC_PROG_LIBTOOL
+
+AC_SUBST(VERSION)
+AC_CONFIG_MACRO_DIR([m4])
+
+m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
+
+###########################
+# Dependencies
+###########################
+
+GTK_REQUIRED_VERSION=2.12
+INDICATOR_REQUIRED_VERSION=0.2.0
+DBUSMENUGTK_REQUIRED_VERSION=0.1.1
+
+PKG_CHECK_MODULES(INDICATOR, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ indicator >= $INDICATOR_REQUIRED_VERSION
+ dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION)
+
+AC_SUBST(INDICATOR_CFLAGS)
+AC_SUBST(INDICATOR_LIBS)
+
+###########################
+# Check to see if we're local
+###########################
+
+with_localinstall="no"
+AC_ARG_ENABLE(localinstall, AS_HELP_STRING([--enable-localinstall], [install all of the files localy instead of system directories (for distcheck)]), with_localinstall=$enableval, with_localinstall=no)
+
+###########################
+# Indicator Info
+###########################
+
+if test "x$with_localinstall" = "xyes"; then
+ INDICATORDIR="${libdir}/indicators/2/"
+ INDICATORICONSDIR="${datadir}/libindicate/icons/"
+else
+ INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator`
+ INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator`
+fi
+AC_SUBST(INDICATORDIR)
+AC_SUBST(INDICATORICONSDIR)
+
+###########################
+# DBus Service Info
+###########################
+
+if test "x$with_localinstall" = "xyes"; then
+ DBUSSERVICEDIR="${datadir}/dbus-1/services/"
+else
+ DBUSSERVICEDIR=`$PKG_CONFIG --variable=session_bus_services_dir dbus-1`
+fi
+AC_SUBST(DBUSSERVICEDIR)
+
+###########################
+# Files
+###########################
+
+AC_OUTPUT([
+Makefile
+src/Makefile
+data/Makefile
+])
+
+###########################
+# Results
+###########################
+
+AC_MSG_NOTICE([
+
+Custom Indicator Configuration:
+
+ Prefix: $prefix
+ Indicator Dir: $INDICATORDIR
+])