aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-12-17 08:37:26 -0600
committerTed Gould <ted@gould.cx>2009-12-17 08:37:26 -0600
commit4d95601ab8c0a97fff79b7362540664d200feb41 (patch)
tree7d31197b4e5cb4f3972631563ce0ffaca7da27d9 /configure.ac
parent7219db0f6c8ff0c62fdae4afced2698d63f39a1a (diff)
parent6af5c9970afd9ea2d9e1192d67fd92438dda8a8c (diff)
downloadayatana-indicator-application-4d95601ab8c0a97fff79b7362540664d200feb41.tar.gz
ayatana-indicator-application-4d95601ab8c0a97fff79b7362540664d200feb41.tar.bz2
ayatana-indicator-application-4d95601ab8c0a97fff79b7362540664d200feb41.zip
Mono build cleanups
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1ff33d8..114b42b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,8 +76,20 @@ if test "x$CSC" = "xno" ; then
AC_MSG_ERROR([No Mono compiler found.])
fi
+AC_PATH_PROG(GACUTIL, gacutil, no)
+if test "x$GACUTIL" = "xno" ; then
+ AC_MSG_ERROR([No gacutil tool found])
+fi
+
+AC_PATH_PROG(SN, sn, no)
+if test "x$SN" = "xno" ; then
+ AC_MSG_ERROR([No sn tool found])
+fi
+
AC_SUBST(RUNTIME)
AC_SUBST(CSC)
+AC_SUBST(GACUTIL)
+AC_SUBST(SN)
AC_SUBST(LIB_PREFIX)
AC_SUBST(LIB_SUFFIX)
AC_SUBST(GENERATED_SOURCES)