aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2009-12-16 14:32:39 -0500
committerKen VanDine <ken.vandine@canonical.com>2009-12-16 14:32:39 -0500
commit4d9d260b7528dc9b1c2f1e205b38f29b34c8c320 (patch)
tree71df84215f1270ae62fe834b3cb863e111a505ff /configure.ac
parent985c449e8efe4e258d286857f6a71a7726b43561 (diff)
parent251da6dc9c3ce7e84e83d734bb08cc42c6db2480 (diff)
downloadayatana-indicator-application-4d9d260b7528dc9b1c2f1e205b38f29b34c8c320.tar.gz
ayatana-indicator-application-4d9d260b7528dc9b1c2f1e205b38f29b34c8c320.tar.bz2
ayatana-indicator-application-4d9d260b7528dc9b1c2f1e205b38f29b34c8c320.zip
merged in python bindings branch and some of my fixes needed for packaging
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ca1793a..1ff33d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -132,6 +132,35 @@ fi
AC_SUBST(DBUSSERVICEDIR)
###########################
+# Python
+###########################
+
+PYGTK_REQUIRED=2.14.0
+PYGOBJECT_REQUIRED=0.22
+
+AM_PATH_PYTHON(2.3.5)
+AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
+
+PKG_CHECK_MODULES(APPINDICATOR_PYTHON,
+ [
+ pygtk-2.0 >= $PYGTK_REQUIRED
+ gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ pygobject-2.0 >= $PYGOBJECT_REQUIRED
+ ])
+AC_SUBST(APPINDICATOR_PYTHON_CFLAGS)
+AC_SUBST(APPINDICATOR_PYTHON_LIBS)
+
+AC_MSG_CHECKING(for pygtk defs)
+PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
+AC_SUBST(PYGTK_DEFSDIR)
+AC_MSG_RESULT($PYGTK_DEFSDIR)
+
+AC_MSG_CHECKING(for pygtk codegen)
+PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
+AC_SUBST(PYGTK_CODEGEN)
+AC_MSG_RESULT($PYGTK_CODEGEN)
+
+###########################
# Files
###########################
@@ -145,6 +174,7 @@ bindings/mono/appindicator-sharp.dll.config
bindings/mono/appindicator-sharp-0.1.pc
bindings/mono/examples/Makefile
bindings/mono/examples/indicator-example
+bindings/python/Makefile
data/Makefile
tests/Makefile
example/Makefile