aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-12-11 20:23:37 -0600
committerTed Gould <ted@gould.cx>2009-12-11 20:23:37 -0600
commita602f4287ef14e95cbaea78c8c676c247a6226fe (patch)
tree525532849c7549ed930f8d58606a0d1f0cd5f4f2 /configure.ac
parentf7ba47b1042091f3181a7dd7ae21e10b03780455 (diff)
downloadayatana-indicator-application-a602f4287ef14e95cbaea78c8c676c247a6226fe.tar.gz
ayatana-indicator-application-a602f4287ef14e95cbaea78c8c676c247a6226fe.tar.bz2
ayatana-indicator-application-a602f4287ef14e95cbaea78c8c676c247a6226fe.zip
Adding the Python build system into the indicator-application one.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 33d296c..4fa8675 100644
--- a/configure.ac
+++ b/configure.ac
@@ -80,6 +80,35 @@ fi
AC_SUBST(DBUSSERVICEDIR)
###########################
+# Python
+###########################
+
+PYGTK_REQUIRED=2.14.0
+APPAPPINDICATOR_REQUIRED=0.0.2
+PYGOBJECT_REQUIRED=0.22
+
+AM_PATH_PYTHON(2.3.5)
+AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
+
+PKG_CHECK_MODULES(APPINDICATOR_PYTHON,
+ [
+ pygtk-2.0 >= $PYGTK_REQUIRED
+ pygobject-2.0 >= $PYGOBJECT_REQUIRED
+ ])
+AC_SUBST(APPINDICATOR_PYTHON_CFLAGS)
+AC_SUBST(APPINDICATOR_PYTHON_LIBS)
+
+AC_MSG_CHECKING(for pygtk defs)
+PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
+AC_SUBST(PYGTK_DEFSDIR)
+AC_MSG_RESULT($PYGTK_DEFSDIR)
+
+AC_MSG_CHECKING(for pygtk codegen)
+PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
+AC_SUBST(PYGTK_CODEGEN)
+AC_MSG_RESULT($PYGTK_CODEGEN)
+
+###########################
# Files
###########################
@@ -87,6 +116,7 @@ AC_OUTPUT([
Makefile
src/Makefile
src/libappindicator/appindicator-0.1.pc
+python/Makefile
data/Makefile
tests/Makefile
example/Makefile