aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-01-20 15:53:17 -0600
committerTed Gould <ted@gould.cx>2010-01-20 15:53:17 -0600
commit5317706e5e2c21962a872f0bbe2cbd948d520e95 (patch)
tree36666b111761bd205d06ef3d4842c40791f06c7e /configure.ac
parentde659683ee9d60ed0fefa2d20c4ff1342f1b94e2 (diff)
downloadayatana-indicator-application-5317706e5e2c21962a872f0bbe2cbd948d520e95.tar.gz
ayatana-indicator-application-5317706e5e2c21962a872f0bbe2cbd948d520e95.tar.bz2
ayatana-indicator-application-5317706e5e2c21962a872f0bbe2cbd948d520e95.zip
Fleshing out loading of the LRU file and realizing we need a json-glib dep and the 'category' field in the output.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ebd6b20..5855168 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,9 +40,11 @@ AC_CONFIG_MACRO_DIR(m4)
GTK_REQUIRED_VERSION=2.12
INDICATOR_REQUIRED_VERSION=0.3.0
DBUSMENUGTK_REQUIRED_VERSION=0.1.1
+JSON_GLIB_REQUIRED_VERSION=0.7.6
PKG_CHECK_MODULES(INDICATOR, gtk+-2.0 >= $GTK_REQUIRED_VERSION
indicator >= $INDICATOR_REQUIRED_VERSION
+ json-glib-1.0 >= $JSON_GLIB_REQUIRED_VERSION
dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION)
AC_SUBST(INDICATOR_CFLAGS)
@@ -51,6 +53,7 @@ AC_SUBST(INDICATOR_LIBS)
###########################
# Check for Mono support
###########################
+
MONO_REQUIRED_VERSION=1.0
PKG_CHECK_MODULES(MONO_DEPENDENCY, mono >= $MONO_REQUIRED_VERSION, has_mono=true, has_mono=false)