aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-09-22 11:42:39 -0500
committerTed Gould <ted@gould.cx>2010-09-22 11:42:39 -0500
commiteab2ebe5b34569ada5f5fda64b9e313b1d9cccca (patch)
tree8e1a0b1e8fc7c33ab4c32653edca75a69c2322ce /configure.ac
parentfe08c86fc6b9d9d843149bf195b995d7e38a2c40 (diff)
downloadayatana-indicator-application-eab2ebe5b34569ada5f5fda64b9e313b1d9cccca.tar.gz
ayatana-indicator-application-eab2ebe5b34569ada5f5fda64b9e313b1d9cccca.tar.bz2
ayatana-indicator-application-eab2ebe5b34569ada5f5fda64b9e313b1d9cccca.zip
Adding a new library line for configure so that we don't end up with extra libs in the library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0ecea51..f1ae2ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,6 +52,13 @@ PKG_CHECK_MODULES(INDICATOR, gtk+-2.0 >= $GTK_REQUIRED_VERSION
AC_SUBST(INDICATOR_CFLAGS)
AC_SUBST(INDICATOR_LIBS)
+PKG_CHECK_MODULES(LIBRARY, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ dbus-glib-1 >= $DBUS_GLIB_REQUIRED_VERSION
+ dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION)
+
+AC_SUBST(LIBRARY_CFLAGS)
+AC_SUBST(LIBRARY_LIBS)
+
###########################
# GObject Introspection
###########################