aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-02-08 11:03:52 -0600
committerTed Gould <ted@gould.cx>2012-02-08 11:03:52 -0600
commit16527352ce17d93f1af9cb7f424ff7335b4032a1 (patch)
tree1fe3ba9eb5e4d6c6cffab518ef4ddc769f6038a7 /configure.ac
parent4e1deeb8bcec30c2cfe994c670695aa7d3044f49 (diff)
parentdd6a60c62c1fc07de49f81b24c3ca3d579f49f6c (diff)
downloadayatana-indicator-application-16527352ce17d93f1af9cb7f424ff7335b4032a1.tar.gz
ayatana-indicator-application-16527352ce17d93f1af9cb7f424ff7335b4032a1.tar.bz2
ayatana-indicator-application-16527352ce17d93f1af9cb7f424ff7335b4032a1.zip
Adding in a code coverage based build target
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d97cbeb..8613550 100644
--- a/configure.ac
+++ b/configure.ac
@@ -70,6 +70,15 @@ AS_IF([test "x$with_gtk" = x3],
)
AM_CONDITIONAL(USE_GTK3, [test "x$with_gtk" = x3])
+###########################
+# gcov coverage reporting
+###########################
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
AC_SUBST(INDICATOR_CFLAGS)
AC_SUBST(INDICATOR_LIBS)
@@ -134,4 +143,5 @@ Application Indicator Configuration:
Prefix: $prefix
Indicator Dir: $INDICATORDIR
GTK+ Version: $with_gtk
+ gcov: $use_gcov
])