aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-06-22 11:12:48 -0500
committerTed Gould <ted@gould.cx>2011-06-22 11:12:48 -0500
commit58f47563b83be3659f2ab12630d3a11d9c426768 (patch)
tree1f3cbb291aae1a0d5ee5af4fb400b3b38f7a9969 /configure.ac
parentb5aec1c606133969188642d2f74f0c96c56bca40 (diff)
downloadayatana-indicator-application-58f47563b83be3659f2ab12630d3a11d9c426768.tar.gz
ayatana-indicator-application-58f47563b83be3659f2ab12630d3a11d9c426768.tar.bz2
ayatana-indicator-application-58f47563b83be3659f2ab12630d3a11d9c426768.zip
Making tests use proper version of libappindicator and cleaning up libappindicator usage to use the same enum headers.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 11 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index c7be913..12d87dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,6 +37,8 @@ DBUSMENUGTK_REQUIRED_VERSION=0.3.91
JSON_GLIB_REQUIRED_VERSION=0.7.6
DBUS_GLIB_REQUIRED_VERSION=0.82
+LIBAPPINDICATOR_REQUIRED_VERSION=0.2.9
+
AC_ARG_WITH([gtk],
[AS_HELP_STRING([--with-gtk],
[Which version of gtk to use @<:@default=3@:>@])],
@@ -49,8 +51,9 @@ AS_IF([test "x$with_gtk" = x3],
json-glib-1.0 >= $JSON_GLIB_REQUIRED_VERSION
dbus-glib-1 >= $DBUS_GLIB_REQUIRED_VERSION
dbusmenu-gtk3-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION)
- AC_SUBST(INDICATOR_CFLAGS)
- AC_SUBST(INDICATOR_LIBS)
+
+ PKG_CHECK_MODULES(APPINDICATOR, appindicator3-0.1 >= $LIBAPPINDICATOR_REQUIRED_VERSION)
+
AC_DEFINE(HAVE_GTK3, 1, [whether gtk3 is available])
],
[test "x$with_gtk" = x2],
@@ -60,24 +63,19 @@ AS_IF([test "x$with_gtk" = x3],
json-glib-1.0 >= $JSON_GLIB_REQUIRED_VERSION
dbus-glib-1 >= $DBUS_GLIB_REQUIRED_VERSION
dbusmenu-gtk-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION)
- AC_SUBST(INDICATOR_CFLAGS)
- AC_SUBST(INDICATOR_LIBS)
+
+ PKG_CHECK_MODULES(APPINDICATOR, appindicator3-0.1 >= $LIBAPPINDICATOR_REQUIRED_VERSION)
],
[AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
)
AM_CONDITIONAL(USE_GTK3, [test "x$with_gtk" = x3])
-LIBAPPINDICATOR_REQUIRED_VERSION=0.2.9
-
-PKG_CHECK_MODULES(TEST, appindicator-0.1 >= $LIBAPPINDICATOR_REQUIRED_VERSION)
-
-AC_SUBST(TEST_CFLAGS)
-AC_SUBST(TEST_LIBS)
+AC_SUBST(INDICATOR_CFLAGS)
+AC_SUBST(INDICATOR_LIBS)
-APP_INDICATOR_INCLUDE_BASE=`$PKG_CONFIG --variable=includedir appindicator-0.1`
-APP_INDICATOR_INCLUDE="$APP_INDICATOR_INCLUDE_BASE/libappindicator-0.1/"
+AC_SUBST(APPINDICATOR_CFLAGS)
+AC_SUBST(APPINDICATOR_LIBS)
-AC_SUBST(APP_INDICATOR_INCLUDE)
###########################
# Check to see if we're local