aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-12-02 16:49:42 -0600
committerTed Gould <ted@gould.cx>2010-12-02 16:49:42 -0600
commit6e2c63951469dff55d6e6236f61bed7c44413459 (patch)
tree7f92d68314959da0c938a988a3db06dde0c139c0 /configure.ac
parent7c3589d667e07d776b8a470bf52a68868aaec182 (diff)
downloadayatana-indicator-application-6e2c63951469dff55d6e6236f61bed7c44413459.tar.gz
ayatana-indicator-application-6e2c63951469dff55d6e6236f61bed7c44413459.tar.bz2
ayatana-indicator-application-6e2c63951469dff55d6e6236f61bed7c44413459.zip
Linking to the install directory of libappindicator for the header files
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 85e0f66..f7506d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,11 +46,16 @@ AC_SUBST(INDICATOR_LIBS)
LIBAPPINDICATOR_REQUIRED_VERSION=0.2.9
-PKG_CHECK_MODULES(TEST, libappindicator >= $LIBAPPINDICATOR_REQUIRED_VERSION)
+PKG_CHECK_MODULES(TEST, appindicator-0.1 >= $LIBAPPINDICATOR_REQUIRED_VERSION)
AC_SUBST(TEST_CFLAGS)
AC_SUBST(TEST_LIBS)
+APP_INDICATOR_INCLUDE_BASE=`$PKG_CONFIG --variable=includedir appindicator-0.1`
+APP_INDICATOR_INCLUDE="$APP_INDICATOR_INCLUDE_BASE/libappindicator-0.1/"
+
+AC_SUBST(APP_INDICATOR_INCLUDE)
+
###########################
# Check to see if we're local
###########################