aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan LeSage <allanlesage@gmail.com>2011-12-06 15:49:39 -0600
committerAllan LeSage <allanlesage@gmail.com>2011-12-06 15:49:39 -0600
commitdd6a60c62c1fc07de49f81b24c3ca3d579f49f6c (patch)
tree4c464bcf120926f79e9f083d26066906c4aeab3b /configure.ac
parentec05da4c7b67aa27d9da78027d4c7d826519c43b (diff)
downloadayatana-indicator-application-dd6a60c62c1fc07de49f81b24c3ca3d579f49f6c.tar.gz
ayatana-indicator-application-dd6a60c62c1fc07de49f81b24c3ca3d579f49f6c.tar.bz2
ayatana-indicator-application-dd6a60c62c1fc07de49f81b24c3ca3d579f49f6c.zip
Added coverage reporting via gcov config and targets.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 33a6260..4011c64 100644
--- a/configure.ac
+++ b/configure.ac
@@ -70,6 +70,15 @@ AS_IF([test "x$with_gtk" = x3],
)
AM_CONDITIONAL(USE_GTK3, [test "x$with_gtk" = x3])
+###########################
+# gcov coverage reporting
+###########################
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
AC_SUBST(INDICATOR_CFLAGS)
AC_SUBST(INDICATOR_LIBS)
@@ -134,4 +143,5 @@ Application Indicator Configuration:
Prefix: $prefix
Indicator Dir: $INDICATORDIR
GTK+ Version: $with_gtk
+ gcov: $use_gcov
])