aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2012-02-08 15:30:51 -0500
committerKen VanDine <ken.vandine@canonical.com>2012-02-08 15:30:51 -0500
commit9b28d1b8e9282555af6ae5bf446b48bb524d92b0 (patch)
tree99a3cc60da48e76a9800bf811fec5a0380b98392 /configure.ac
parent0e850ccfad0da834f02a14fe9df7811e6ba740ee (diff)
parent6350c370495334192d5edc540acf7235eeeaa32c (diff)
downloadayatana-indicator-application-9b28d1b8e9282555af6ae5bf446b48bb524d92b0.tar.gz
ayatana-indicator-application-9b28d1b8e9282555af6ae5bf446b48bb524d92b0.tar.bz2
ayatana-indicator-application-9b28d1b8e9282555af6ae5bf446b48bb524d92b0.zip
* New upstream release.
* Adding in a code coverage based build target * Fixing useless variable setting * Fixing variant usage * Adding support for the Title property * Fixing to work with Dbusmenu 0.5.90 * debian/control: Dbusmenu bump to 0.5.90
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 33a6260..18c918c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,11 +1,11 @@
-AC_INIT(indicator-application, 0.4.0, ted@canonical.com)
+AC_INIT(indicator-application, 0.4.90, ted@canonical.com)
AC_COPYRIGHT([Copyright 2009, 2010 Canonical])
AC_PREREQ(2.53)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(indicator-application, 0.4.0)
+AM_INIT_AUTOMAKE(indicator-application, 0.4.90)
AM_MAINTAINER_MODE
@@ -33,7 +33,7 @@ GTK_REQUIRED_VERSION=2.18
GTK3_REQUIRED_VERSION=2.91
GIO_REQUIRED_VERSION=2.26
INDICATOR_REQUIRED_VERSION=0.3.5
-DBUSMENUGTK_REQUIRED_VERSION=0.3.91
+DBUSMENUGTK_REQUIRED_VERSION=0.5.90
JSON_GLIB_REQUIRED_VERSION=0.7.6
DBUS_GLIB_REQUIRED_VERSION=0.82
@@ -70,6 +70,15 @@ AS_IF([test "x$with_gtk" = x3],
)
AM_CONDITIONAL(USE_GTK3, [test "x$with_gtk" = x3])
+###########################
+# gcov coverage reporting
+###########################
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
AC_SUBST(INDICATOR_CFLAGS)
AC_SUBST(INDICATOR_LIBS)
@@ -134,4 +143,5 @@ Application Indicator Configuration:
Prefix: $prefix
Indicator Dir: $INDICATORDIR
GTK+ Version: $with_gtk
+ gcov: $use_gcov
])