aboutsummaryrefslogtreecommitdiff
path: root/data/upstart/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2014-02-19 21:27:31 -0600
committerTed Gould <ted@gould.cx>2014-02-19 21:27:31 -0600
commitf179a2c7f91497854fa787eb0c65e547a791f038 (patch)
tree47fac92119d9a69049a08af9ece4e1e815c28057 /data/upstart/Makefile.am
parentc6a36f4305d52fb74d9990174fb9c455c01f4014 (diff)
downloadayatana-indicator-application-f179a2c7f91497854fa787eb0c65e547a791f038.tar.gz
ayatana-indicator-application-f179a2c7f91497854fa787eb0c65e547a791f038.tar.bz2
ayatana-indicator-application-f179a2c7f91497854fa787eb0c65e547a791f038.zip
Build the upstart desktop file in its own directory
Diffstat (limited to 'data/upstart/Makefile.am')
-rw-r--r--data/upstart/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/data/upstart/Makefile.am b/data/upstart/Makefile.am
new file mode 100644
index 0000000..a384c75
--- /dev/null
+++ b/data/upstart/Makefile.am
@@ -0,0 +1,9 @@
+
+xdg_autostartdir = $(datadir)/upstart/xdg/autostart
+xdg_autostart_DATA = indicator-application.desktop
+
+%.desktop: %.desktop.in
+ sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
+
+EXTRA_DIST = \
+ indicator-application.desktop.in