aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2009-12-16 14:37:40 -0500
committerKen VanDine <ken.vandine@canonical.com>2009-12-16 14:37:40 -0500
commit2a5cad3851390bf7a875d40cb525ddbe6ec8a6c2 (patch)
tree53181f5ab087552e3b9c026972f80015860e34a5 /debian
parent53d5f10ac0667f455de2b3e5553647545345b062 (diff)
downloadayatana-indicator-application-2a5cad3851390bf7a875d40cb525ddbe6ec8a6c2.tar.gz
ayatana-indicator-application-2a5cad3851390bf7a875d40cb525ddbe6ec8a6c2.tar.bz2
ayatana-indicator-application-2a5cad3851390bf7a875d40cb525ddbe6ec8a6c2.zip
* debian/rules
- don't use gnome.mk, specify all the targets to build python bindings for each supported python version * Adding in Python bindings. * debian/control, debian/python-appindicator.install: Building a binary package for the python bindings. * debian/control: Adding python building build deps
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog14
-rw-r--r--debian/control28
-rw-r--r--debian/python-appindicator.install2
-rwxr-xr-xdebian/rules56
4 files changed, 93 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index d8bcdb0..59b490a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+indicator-application (0.0.4.1-0ubuntu1) UNRELEASED; urgency=low
+
+ * debian/rules
+ - don't use gnome.mk, specify all the targets to build python
+ bindings for each supported python version
+
+ [Ted Gould]
+ * Adding in Python bindings.
+ * debian/control, debian/python-appindicator.install: Building
+ a binary package for the python bindings.
+ * debian/control: Adding python building build deps
+
+ -- Ken VanDine <ken.vandine@canonical.com> Wed, 16 Dec 2009 14:36:05 -0500
+
indicator-application (0.0.4-0ubuntu2) lucid; urgency=low
* debian/control
diff --git a/debian/control b/debian/control
index f0efd54..03f2e49 100644
--- a/debian/control
+++ b/debian/control
@@ -1,14 +1,18 @@
Source: indicator-application
Section: gnome
Priority: optional
+XS-Python-Version: all
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Build-Depends: debhelper (>= 5.0),
cdbs (>= 0.4.41),
+ python-central (>= 0.6),
libgtk2.0-dev (>= 2.12.0),
libdbus-glib-1-dev,
gnome-doc-utils,
gtk-doc-tools,
intltool,
+ python-all-dev,
+ python-gtk2-dev,
libindicate-dev (>= 0.2.0),
libindicate-gtk-dev (>= 0.2.0),
libindicator-dev (>= 0.3.0),
@@ -18,11 +22,25 @@ Standards-Version: 3.8.3
Homepage: https://launchpad.net/indicator-application
Vcs-Bzr: http://bazaar.launchpad.net/~ubuntu-desktop/indicator-application/ubuntu
+Package: python-appindicator
+Section: python
+Architecture: any
+XB-Python-Version: ${python:Versions}
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ ${python:Depends},
+ libappindicator0 (= ${binary:Version}),
+ python-gobject
+Provides: ${python:Provides}
+Description: Python bindings for libappindicator
+ This package provides Python bindings so that you can use libappindicator from
+ a Python program.
+
Package: indicator-application
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: Application Indicators
- A library and indicator to take menus from applications and place them in
+ A library and indicator to take menus from applications and place them in
the panel.
Package: libappindicator0
@@ -32,10 +50,10 @@ Depends: ${shlibs:Depends},
${misc:Depends}
Recommends: indicator-application (= ${binary:Version})
Description: Application Indicators
- A library and indicator to take menus from applications and place them in
+ A library and indicator to take menus from applications and place them in
the panel.
.
- This package contains shared libraries to be used by applications.
+ This package contains shared libraries to be used by applications.
Package: libappindicator-dev
Section: libdevel
@@ -46,7 +64,7 @@ Depends: ${shlibs:Depends},
libdbus-glib-1-dev (>= 0.76),
libappindicator0 (= ${binary:Version})
Description: Application Indicators
- A library and indicator to take menus from applications and place them in
+ A library and indicator to take menus from applications and place them in
the panel.
.
This package contains files that are needed to build applications.
@@ -60,4 +78,4 @@ Description: Application Indicators
A library and indicator to take menus from applications and place them in
the panel.
.
- This package contains development documentation.
+
diff --git a/debian/python-appindicator.install b/debian/python-appindicator.install
new file mode 100644
index 0000000..7a7f049
--- /dev/null
+++ b/debian/python-appindicator.install
@@ -0,0 +1,2 @@
+debian/tmp/usr/lib/python2.6/*
+debian/tmp/usr/share/pygtk/*
diff --git a/debian/rules b/debian/rules
index 1d2f7dd..41fbfb0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,64 @@
#!/usr/bin/make -f
+
+DEB_PYTHON_SYSTEM=pycentral
+PY_VERSIONS = $(shell pyversions --requested debian/control)
+
include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/gnome.mk
+include /usr/share/cdbs/1/class/autotools-vars.mk
include /usr/share/cdbs/1/rules/simple-patchsys.mk
DEB_CONFIGURE_EXTRA_FLAGS += --enable-gtk-doc
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
+
+configure-stamp-%:
+ mkdir build-$*
+ cd build-$* && PYTHON=`which $*` \
+ $(DEB_CONFIGURE_SCRIPT) $(DEB_CONFIGURE_NORMAL_ARGS) --srcdir=..
+ touch $@
+
+configure/python-appindicator:: $(addprefix configure-stamp-, $(PY_VERSIONS))
+
+build-stamp-%:
+ make -C build-$*/python
+ touch $@
+
+build/python-appindicator:: $(addprefix build-stamp-, $(PY_VERSIONS))
+
+install-stamp-%:
+ make -C build-$*/python install DESTDIR=$(CURDIR)/debian/tmp
+ touch $@
+
+install/python-appindicator:: $(addprefix install-stamp-, $(PY_VERSIONS))
+
+
+binary-install/python-appindicator::
+ dh_pycentral
+
+configure-stamp:
+ $(DEB_CONFIGURE_SCRIPT) $(DEB_CONFIGURE_NORMAL_ARGS) $(DEB_CONFIGURE_EXTRA_FLAGS)
+ touch $@
+
+configure/indicator-application:: configure-stamp
+
+build-stamp:
+ make
+ touch $@
+
+build/indicator-application:: build-stamp
+
+install-stamp:
+ make install DESTDIR=$(CURDIR)/debian/tmp
+ touch $@
+
+install/indicator-application:: install-stamp
binary-post-install/indicator-application::
find debian/indicator-application/usr/lib -name \*.la -exec rm {} \;
find debian/indicator-application/usr/lib -name \*.a -exec rm {} \;
+
+clean::
+ -rm -rf $(addprefix build-, $(PY_VERSIONS))
+ -rm -rf $(addprefix configure-stamp-, $(PY_VERSIONS))
+ -rm -rf $(addprefix build-stamp-, $(PY_VERSIONS))
+ -rm -rf $(addprefix install-stamp-, $(PY_VERSIONS))
+