aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2010-02-19 12:24:17 -0500
committerKen VanDine <ken.vandine@canonical.com>2010-02-19 12:24:17 -0500
commita889ee7685e4d5d5cf8fe51467eb9ad8121475a1 (patch)
treed2ac1c012f6e70d31617d73c3d429cdfa60e3b70 /debian
parentb1e72a50c92348a707396990cea5474143bff8cf (diff)
downloadayatana-indicator-application-a889ee7685e4d5d5cf8fe51467eb9ad8121475a1.tar.gz
ayatana-indicator-application-a889ee7685e4d5d5cf8fe51467eb9ad8121475a1.tar.bz2
ayatana-indicator-application-a889ee7685e4d5d5cf8fe51467eb9ad8121475a1.zip
* Cherrypick fix to check for a null string as the attention icon
* Cherrypick fix to remove the registration of dbus objects (LP: #497870) - lets us drop debian/patches/unregister.patch
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches/unregister.patch39
2 files changed, 3 insertions, 40 deletions
diff --git a/debian/changelog b/debian/changelog
index da11c18..ce7af3d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
indicator-application (0.0.13-0ubuntu6) lucid; urgency=low
- * Cherry picked fix to check for a null string as the attention icon
+ * Cherrypick fix to check for a null string as the attention icon
+ * Cherrypick fix to remove the registration of dbus objects (LP: #497870)
+ - lets us drop debian/patches/unregister.patch
-- Ken VanDine <ken.vandine@canonical.com> Fri, 19 Feb 2010 12:21:39 -0500
diff --git a/debian/patches/unregister.patch b/debian/patches/unregister.patch
deleted file mode 100644
index 87b2bb2..0000000
--- a/debian/patches/unregister.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-=== modified file 'src/libappindicator/app-indicator.c'
---- src/libappindicator/app-indicator.c 2010-02-17 22:04:09 +0000
-+++ src/libappindicator/app-indicator.c 2010-02-19 15:21:19 +0000
-@@ -598,6 +598,7 @@
- if (priv->id == NULL) return;
-
- gchar * path = g_strdup_printf(DEFAULT_ITEM_PATH "/%s", priv->clean_id);
-+
- dbus_g_connection_register_g_object(priv->connection,
- path,
- G_OBJECT(self));
-@@ -612,6 +613,8 @@
- /* Unable to get proxy, but we're handling that now so
- it's not a warning anymore. */
- g_error_free(error);
-+ dbus_g_connection_unregister_g_object(priv->connection,
-+ G_OBJECT(self));
- start_fallback_timer(self, FALSE);
- g_free(path);
- return;
-@@ -632,6 +635,8 @@
- AppIndicator * self = APP_INDICATOR(data);
- g_return_if_fail(self != NULL);
-
-+ dbus_g_connection_unregister_g_object(self->priv->connection,
-+ G_OBJECT(self));
- self->priv->watcher_proxy = NULL;
- start_fallback_timer(self, FALSE);
- return;
-@@ -649,6 +654,8 @@
- /* They didn't respond, ewww. Not sure what they could
- be doing */
- g_warning("Unable to connect to the Notification Watcher: %s", error->message);
-+ dbus_g_connection_unregister_g_object(priv->connection,
-+ G_OBJECT(data));
- g_object_unref(G_OBJECT(priv->watcher_proxy));
- priv->watcher_proxy = NULL;
- start_fallback_timer(APP_INDICATOR(data), TRUE);
-