aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-12-08 13:00:55 -0600
committerTed Gould <ted@gould.cx>2010-12-08 13:00:55 -0600
commit3acbfb57c4800b7f8611d1ce5db391cad96f398b (patch)
treeaf6de92d556ec059754ea4f594259601d6b98a9c /debian
parentc05b64af5fc28789f404629d64a1ade4d6c6da34 (diff)
parentb917f6f3aba462d98c6690d650ef8555e736c4f8 (diff)
downloadayatana-indicator-application-3acbfb57c4800b7f8611d1ce5db391cad96f398b.tar.gz
ayatana-indicator-application-3acbfb57c4800b7f8611d1ce5db391cad96f398b.tar.bz2
ayatana-indicator-application-3acbfb57c4800b7f8611d1ce5db391cad96f398b.zip
Merge from Ubuntu Desktop for dual builds
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog29
-rw-r--r--debian/control7
-rw-r--r--debian/python-appindicator.install2
-rwxr-xr-xdebian/rules34
4 files changed, 55 insertions, 17 deletions
diff --git a/debian/changelog b/debian/changelog
index 4d1bbf9..643534e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,12 +1,37 @@
-indicator-application (0.2.90-0ubuntu1~ppa1) natty; urgency=low
+indicator-application (0.2.90-0ubuntu3) UNRELEASED; urgency=low
+ * debian/control
+ - build depend on dbusmenu >= 0.3.90
+
+ -- Ken VanDine <ken.vandine@canonical.com> Wed, 08 Dec 2010 13:32:07 -0500
+
+indicator-application (0.2.90-0ubuntu2) natty; urgency=low
+
+ * debian/rules
+ - Convert to dh_python2
+ * debian/control
+ - Dropped build depends for python-central
+
+ -- Ken VanDine <ken.vandine@canonical.com> Wed, 08 Dec 2010 12:03:47 -0500
+
+indicator-application (0.2.90-0ubuntu1) natty; urgency=low
+
+ [ Ted Gould ]
* New upstream release.
* A race fix on the dbus name (LP: #526499)
* Fixing the Watcher Interface
* Fixes to build with GTK 2/3
* Fixes to build with valac-0.12
- -- Ted Gould <ted@ubuntu.com> Tue, 07 Dec 2010 20:50:15 -0600
+ [ Ken VanDine ]
+ * debian/control
+ - Changed the valac build depends to valac-0.12
+ * debian/python-appindicator.install
+ - Make sure python2.6 and python2.7 files get included
+ * debian/rules
+ - Fix builds for multiple python versions
+
+ -- Ken VanDine <ken.vandine@canonical.com> Wed, 08 Dec 2010 00:42:58 -0500
indicator-application (0.2.9-0ubuntu1) maverick; urgency=low
diff --git a/debian/control b/debian/control
index 87682af..44e5ea1 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,6 @@ XS-Python-Version: all
Maintainer: Ubuntu Desktop Team <ubuntu-desktop@lists.ubuntu.com>
Build-Depends: debhelper (>= 5.0),
cdbs (>= 0.4.41),
- python-central (>= 0.6),
libgtk2.0-dev (>= 2.12.0),
libdbus-glib-1-dev (>= 0.82),
libjson-glib-dev,
@@ -17,8 +16,8 @@ Build-Depends: debhelper (>= 5.0),
libindicate-dev (>= 0.2.0),
libindicate-gtk-dev (>= 0.2.0),
libindicator-dev (>= 0.3.14),
- libdbusmenu-gtk-dev (>= 0.2.2),
- libdbusmenu-glib-dev (>= 0.2.2),
+ libdbusmenu-gtk-dev (>= 0.3.90),
+ libdbusmenu-glib-dev (>= 0.3.90),
cli-common-dev (>= 0.5.7),
mono-devel (>= 2.4.3),
gtk-sharp2-gapi,
@@ -29,7 +28,7 @@ Build-Depends: debhelper (>= 5.0),
libgirepository1.0-dev,
gir1.0-glib-2.0,
gir1.0-gtk-2.0,
- valac
+ valac-0.12
Standards-Version: 3.8.4
Homepage: https://launchpad.net/indicator-application
Vcs-Bzr: http://bazaar.launchpad.net/~ubuntu-desktop/indicator-application/ubuntu
diff --git a/debian/python-appindicator.install b/debian/python-appindicator.install
index 7a7f049..00bdd51 100644
--- a/debian/python-appindicator.install
+++ b/debian/python-appindicator.install
@@ -1,2 +1,2 @@
-debian/tmp/usr/lib/python2.6/*
+debian/tmp/usr/lib/python2.*
debian/tmp/usr/share/pygtk/*
diff --git a/debian/rules b/debian/rules
index 6e31d41..cfb2f4b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,9 @@
#!/usr/bin/make -f
-DEB_PYTHON_SYSTEM=pycentral
+DEB_SRCDIR = .
+DEB_BUILDDIR = $(DEB_SRCDIR)/build
+
+DEB_PYTHON_SYSTEM=dh_python2
PY_VERSIONS = $(shell pyversions --requested debian/control)
export MONO_SHARED_DIR=$(CURDIR)
export CSC=/usr/bin/mono-csc
@@ -8,7 +11,6 @@ export CSC=/usr/bin/mono-csc
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/autotools-vars.mk
include /usr/share/cdbs/1/rules/utils.mk
-include /usr/share/cdbs/1/rules/simple-patchsys.mk
DEB_CONFIGURE_EXTRA_FLAGS += --enable-gtk-doc
API_VERSION = 0.1
@@ -24,19 +26,25 @@ configure-stamp-%:
configure/python-appindicator:: $(addprefix configure-stamp-, $(PY_VERSIONS))
build-stamp-%:
- make -C build-$*/bindings/python
+ PYTHON=`which $*` \
+ $(MAKE) -C build-$*
touch $@
build/python-appindicator:: $(addprefix build-stamp-, $(PY_VERSIONS))
install-stamp-%:
- make -C build-$*/bindings/python install DESTDIR=$(CURDIR)/debian/tmp
+ PYTHON=`which $*` \
+ $(MAKE) -C build-$*/bindings/python install DESTDIR=$(CURDIR)/debian/tmp
+ dh_installdirs -ppython-appindicator -s
+ dh_install -ppython-appindicator -s
touch $@
install/python-appindicator:: $(addprefix install-stamp-, $(PY_VERSIONS))
-binary-install/python-appindicator::
- dh_pycentral
+binary-predeb/python-appindicator::
+ dh_python2 -ppython-appindicator
+ find debian/python-appindicator/usr/lib -name \*.la -exec rm {} \;
+ find debian/python-appindicator/usr/lib -name \*.a -exec rm {} \;
binary-install/libappindicator0.1-cil::
dh_clistrip
@@ -51,28 +59,35 @@ binary-predeb/libappindicator0.1-cil:: binary-fixup/libappindicator1
dh_clideps -plibappindicator0.1-cil
configure-stamp:
- $(DEB_CONFIGURE_SCRIPT) $(DEB_CONFIGURE_NORMAL_ARGS) $(DEB_CONFIGURE_EXTRA_FLAGS)
+ cd $(DEB_BUILDDIR) && \
+ $(DEB_CONFIGURE_SCRIPT) $(DEB_CONFIGURE_NORMAL_ARGS) $(DEB_CONFIGURE_EXTRA_FLAGS)
touch $@
configure/indicator-application:: configure-stamp
build-stamp:
- make
+ $(MAKE) -C $(DEB_BUILDDIR)
touch $@
build/indicator-application:: build-stamp
install-stamp:
- make install DESTDIR=$(CURDIR)/debian/tmp
+ $(MAKE) -C $(DEB_BUILDDIR) install DESTDIR=$(CURDIR)/debian/tmp
touch $@
install/indicator-application:: install-stamp
+binary-predeb/libappindicator1:: install-stamp
+ dh_fixperms
+ dh_strip
+
binary-post-install/indicator-application::
find debian/indicator-application/usr/lib -name \*.la -exec rm {} \;
find debian/indicator-application/usr/lib -name \*.a -exec rm {} \;
common-binary-predeb-arch:: list-missing
+ dh_fixperms
+ dh_strip
clean::
-rm -rf $(addprefix build-, $(PY_VERSIONS))
@@ -80,4 +95,3 @@ clean::
-rm -rf $(addprefix build-stamp-, $(PY_VERSIONS))
-rm -rf $(addprefix install-stamp-, $(PY_VERSIONS))
rm -rf $(MONO_SHARED_DIR)/.wapi
-