aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2010-12-08 13:10:00 -0500
committerKen VanDine <ken.vandine@canonical.com>2010-12-08 13:10:00 -0500
commita227646d51c40f97e0c3b56d7b9440d198a121ff (patch)
tree969c48436179034ea59e46f334ad24f945d867aa /debian
parent1860f397fba552cfa443413e543a8b5d583ca2f0 (diff)
downloadayatana-indicator-application-a227646d51c40f97e0c3b56d7b9440d198a121ff.tar.gz
ayatana-indicator-application-a227646d51c40f97e0c3b56d7b9440d198a121ff.tar.bz2
ayatana-indicator-application-a227646d51c40f97e0c3b56d7b9440d198a121ff.zip
releasing version 0.2.90-0ubuntu2
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog9
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules9
3 files changed, 15 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 3098337..3936136 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+indicator-application (0.2.90-0ubuntu2) natty; urgency=low
+
+ * debian/rules
+ - Convert to dh_python2
+ * debian/control
+ - Dropped build depends for python-central
+
+ -- Ken VanDine <ken.vandine@canonical.com> Wed, 08 Dec 2010 12:03:47 -0500
+
indicator-application (0.2.90-0ubuntu1) natty; urgency=low
[ Ted Gould ]
diff --git a/debian/control b/debian/control
index 2114116..1a24f2b 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,6 @@ XS-Python-Version: all
Maintainer: Ubuntu Desktop Team <ubuntu-desktop@lists.ubuntu.com>
Build-Depends: debhelper (>= 5.0),
cdbs (>= 0.4.41),
- python-central (>= 0.6),
libgtk2.0-dev (>= 2.12.0),
libdbus-glib-1-dev (>= 0.82),
libjson-glib-dev,
diff --git a/debian/rules b/debian/rules
index 23237d2..cfb2f4b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
DEB_SRCDIR = .
DEB_BUILDDIR = $(DEB_SRCDIR)/build
-DEB_PYTHON_SYSTEM=pycentral
+DEB_PYTHON_SYSTEM=dh_python2
PY_VERSIONS = $(shell pyversions --requested debian/control)
export MONO_SHARED_DIR=$(CURDIR)
export CSC=/usr/bin/mono-csc
@@ -42,7 +42,9 @@ install-stamp-%:
install/python-appindicator:: $(addprefix install-stamp-, $(PY_VERSIONS))
binary-predeb/python-appindicator::
- DH_PYCENTRAL=include-links dh_pycentral -ppython-appindicator -s
+ dh_python2 -ppython-appindicator
+ find debian/python-appindicator/usr/lib -name \*.la -exec rm {} \;
+ find debian/python-appindicator/usr/lib -name \*.a -exec rm {} \;
binary-install/libappindicator0.1-cil::
dh_clistrip
@@ -84,6 +86,8 @@ binary-post-install/indicator-application::
find debian/indicator-application/usr/lib -name \*.a -exec rm {} \;
common-binary-predeb-arch:: list-missing
+ dh_fixperms
+ dh_strip
clean::
-rm -rf $(addprefix build-, $(PY_VERSIONS))
@@ -91,4 +95,3 @@ clean::
-rm -rf $(addprefix build-stamp-, $(PY_VERSIONS))
-rm -rf $(addprefix install-stamp-, $(PY_VERSIONS))
rm -rf $(MONO_SHARED_DIR)/.wapi
-