aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-06-22 13:26:15 -0400
committerKen VanDine <ken.vandine@canonical.com>2011-06-22 13:26:15 -0400
commitf2c00ec02764df9af713482b63712f1058c6d19f (patch)
tree16051d9d9e530d91a46462a5c9f743a74ddf9da6 /debian
parent3315ba58c8f79fc1d1fcb50098e231aefd32a625 (diff)
downloadayatana-indicator-application-f2c00ec02764df9af713482b63712f1058c6d19f.tar.gz
ayatana-indicator-application-f2c00ec02764df9af713482b63712f1058c6d19f.tar.bz2
ayatana-indicator-application-f2c00ec02764df9af713482b63712f1058c6d19f.zip
releasing version 0.3.90-0ubuntu1
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog17
-rw-r--r--debian/control24
-rw-r--r--debian/indicator-application-gtk2.install1
-rw-r--r--debian/indicator-application.install1
-rwxr-xr-xdebian/rules24
5 files changed, 51 insertions, 16 deletions
diff --git a/debian/changelog b/debian/changelog
index f4e81ac..48b0a6b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,22 @@
-indicator-application (0.3.90-0ubuntu1~ppa1) oneiric; urgency=low
+indicator-application (0.3.90-0ubuntu1) oneiric; urgency=low
+ [ Ted Gould ]
* New upstream release.
* GTK3 Port
- -- Ted Gould <ted@ubuntu.com> Wed, 22 Jun 2011 11:37:43 -0500
+ [ Ken VanDine ]
+ * debian/control
+ - Bumped standards version to 3.9.2
+ - Add new binary for indicator-application-gtk2
+ - Make indicator-application recommend indicator-application-gtk2 (until
+ unity can load gtk3 indicators)
+ - indicator-application-gtk2 replaces indicator-application << 0.2.90
+ - Added build depends for libdbusmenu-gtk3-dev, libindicator3-dev
+ and libappindicator3-dev
+ * debian/rules
+ - build for both gtk2 and gtk3
+
+ -- Ken VanDine <ken.vandine@canonical.com> Wed, 22 Jun 2011 13:07:06 -0400
indicator-application (0.3.2-0ubuntu1) natty; urgency=low
diff --git a/debian/control b/debian/control
index a1f6be0..a1e7a78 100644
--- a/debian/control
+++ b/debian/control
@@ -5,22 +5,36 @@ XS-Python-Version: all
Maintainer: Ubuntu Desktop Team <ubuntu-desktop@lists.ubuntu.com>
Build-Depends: debhelper (>= 5.0),
cdbs (>= 0.4.41),
- quilt,
libgtk2.0-dev (>= 2.12.0),
+ libgtk-3-dev (>= 2.91),
libdbus-glib-1-dev (>= 0.82),
libjson-glib-dev,
intltool,
+ libappindicator-dev (>= 0.2.91),
+ libappindicator3-dev (>= 0.2.91),
libindicator-dev (>= 0.3.19),
- libdbusmenu-gtk-dev (>= 0.3.91),
- libdbusmenu-glib-dev (>= 0.3.91),
- libappindicator-dev (>= 0.2.91)
-Standards-Version: 3.8.4
+ libindicator3-dev (>= 0.3.19),
+ libdbusmenu-glib-dev (>= 0.3.94),
+ libdbusmenu-gtk-dev (>= 0.3.94),
+ libdbusmenu-gtk3-dev (>= 0.3.94)
+Standards-Version: 3.9.2
Homepage: https://launchpad.net/indicator-application
Vcs-Bzr: http://bazaar.launchpad.net/~ubuntu-desktop/indicator-application/ubuntu
Package: indicator-application
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
+Recommends: indicator-application-gtk2
+Description: Application Indicators
+ A library and indicator to take menus from applications and place them in
+ the panel.
+
+Package: indicator-application-gtk2
+Architecture: any
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ indicator-application (= ${binary:Version})
+Replaces: indicator-application (<< 0.3.90)
Description: Application Indicators
A library and indicator to take menus from applications and place them in
the panel.
diff --git a/debian/indicator-application-gtk2.install b/debian/indicator-application-gtk2.install
new file mode 100644
index 0000000..8d1fc9f
--- /dev/null
+++ b/debian/indicator-application-gtk2.install
@@ -0,0 +1 @@
+debian/tmp/gtk2/usr/lib/indicators /usr/lib/
diff --git a/debian/indicator-application.install b/debian/indicator-application.install
new file mode 100644
index 0000000..19a45de
--- /dev/null
+++ b/debian/indicator-application.install
@@ -0,0 +1 @@
+debian/tmp/gtk3/usr /
diff --git a/debian/rules b/debian/rules
index 7a7c9e8..7950ed1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,17 +1,23 @@
#!/usr/bin/make -f
+DEB_BUILDDIR = build
+DEB_MAKE_FLAVORS = gtk2 gtk3
+
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/gnome.mk
-include /usr/share/cdbs/1/rules/utils.mk
-include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
+DEB_MAKE_DESTDIRSKEL = $(CURDIR)/debian/tmp/@FLAVOR@
+DEB_DESTDIR = $(CURDIR)/debian/tmp/$(cdbs_make_curflavor)/
-common-binary-predeb-arch:: list-missing
+DEB_CONFIGURE_FLAGS_gtk2 = --with-gtk=2
+DEB_CONFIGURE_FLAGS_gtk3 = --with-gtk=3
+DEB_CONFIGURE_EXTRA_FLAGS = --disable-static
+
+LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-DEB_DH_MAKESHLIBS_ARGS = -Xusr/lib/indicators
+debian/stamp-autotools/gtk2: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk2)
+debian/stamp-autotools/gtk3: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk3)
-binary-install/indicator-application::
- # remove .a/.la clutter
- rm -f debian/$(cdbs_curpkg)/usr/lib/indicators/*/*.a
- rm -f debian/$(cdbs_curpkg)/usr/lib/indicators/*/*.la
+common-install-arch::
+ find debian/tmp -name \*.la -delete
+ find debian/tmp -name \*.a -delete