aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-08-10 12:06:04 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-08-10 12:06:04 +0200
commitac816c04496b2ba5152cbb15d07c4ddfa75e6bf8 (patch)
tree95e595fab5ec4ed65b20e0fbe55cec8c6b6411e0 /debian
parentbcd0095dcfe96c49c3079d9e22752e1e7e5857fe (diff)
downloadayatana-indicator-application-ac816c04496b2ba5152cbb15d07c4ddfa75e6bf8.tar.gz
ayatana-indicator-application-ac816c04496b2ba5152cbb15d07c4ddfa75e6bf8.tar.bz2
ayatana-indicator-application-ac816c04496b2ba5152cbb15d07c4ddfa75e6bf8.zip
debian/*: Install systemd user service file correctly into DEB package.
Diffstat (limited to 'debian')
-rw-r--r--debian/ayatana-indicator-application.links3
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules2
3 files changed, 5 insertions, 1 deletions
diff --git a/debian/ayatana-indicator-application.links b/debian/ayatana-indicator-application.links
new file mode 100644
index 0000000..c4581ab
--- /dev/null
+++ b/debian/ayatana-indicator-application.links
@@ -0,0 +1,3 @@
+# Because dh-systemd does not support user units for compat levels below 12, we manually make the WantedBy link
+# FIXME: drop this once we bump DH compat level to 12 or higher
+/usr/lib/systemd/user/ayatana-indicator-application.service /usr/lib/systemd/user/ayatana-indicators.target.wants/ayatana-indicator-application.service
diff --git a/debian/control b/debian/control
index ebcc2b7..42fd4b7 100644
--- a/debian/control
+++ b/debian/control
@@ -4,6 +4,7 @@ Priority: optional
Maintainer: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Build-Depends: debhelper (>= 9.0),
dh-autoreconf | debhelper (>= 9.20160403~),
+ dh-systemd | debhelper (>= 10.2~),
dbus-test-runner,
mate-common,
xvfb,
diff --git a/debian/rules b/debian/rules
index 6310980..c7aa8a6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
export DPKG_GENSYMBOLS_CHECK_LEVEL=4
%:
- dh $@ --with autoreconf
+ dh $@ --with autoreconf,systemd
override_dh_autoreconf:
NOCONFIGURE=1 dh_autoreconf ./autogen.sh