aboutsummaryrefslogtreecommitdiff
path: root/docs/reference/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-12-09 14:17:40 -0600
committerTed Gould <ted@gould.cx>2009-12-09 14:17:40 -0600
commit5ed93632aebf97741acf96cb0ad098955b35b0fe (patch)
treef89741b80c6dc0d36fb38d8c723a769c6435cde9 /docs/reference/Makefile.am
parentecd7cd9eaece64e278d3386a9f03a98b4901401b (diff)
parente4cdb13a8f940e6cefb757fac5fc038b7310ce22 (diff)
downloadayatana-indicator-application-5ed93632aebf97741acf96cb0ad098955b35b0fe.tar.gz
ayatana-indicator-application-5ed93632aebf97741acf96cb0ad098955b35b0fe.tar.bz2
ayatana-indicator-application-5ed93632aebf97741acf96cb0ad098955b35b0fe.zip
Fixing up documentation and making it error if symbols are missing.
Diffstat (limited to 'docs/reference/Makefile.am')
-rw-r--r--docs/reference/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/docs/reference/Makefile.am b/docs/reference/Makefile.am
index e2a02cd..67582f2 100644
--- a/docs/reference/Makefile.am
+++ b/docs/reference/Makefile.am
@@ -91,5 +91,12 @@ EXTRA_DIST += version.xml.in
#DISTCLEANFILES +=
# Comment this out if you want your docs-status tested during 'make check'
-#TESTS = $(GTKDOC_CHECK)
+TESTS = gtkdoc-in-srcdir
+
+gtkdoc-in-srcdir: Makefile.am
+ @echo "#!/bin/sh" > $@
+ @echo "cd \"$(srcdir)\"" >> $@
+ @echo "$(GTKDOC_CHECK)" >> $@
+ @chmod +x $@
+DISTCLEANFILES = gtkdoc-in-srcdir