aboutsummaryrefslogtreecommitdiff
path: root/docs/reference/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-05-20 14:39:17 -0500
committerTed Gould <ted@gould.cx>2010-05-20 14:39:17 -0500
commite09b4591cf46334934a233511b18d7706802bd35 (patch)
tree0f992ea5cd6b4f859927f298090386dea54f7018 /docs/reference/Makefile.am
parentea79d7fd68a100704d2b1ff883497fef0ce8c3a2 (diff)
parent0b091646a8ecf62c36cde27a1d0e784a55e9a0c2 (diff)
downloadayatana-indicator-application-e09b4591cf46334934a233511b18d7706802bd35.tar.gz
ayatana-indicator-application-e09b4591cf46334934a233511b18d7706802bd35.tar.bz2
ayatana-indicator-application-e09b4591cf46334934a233511b18d7706802bd35.zip
Adding GIR/VAPI support and flattening directories
Diffstat (limited to 'docs/reference/Makefile.am')
-rw-r--r--docs/reference/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/docs/reference/Makefile.am b/docs/reference/Makefile.am
index 1292f4d..3aedd60 100644
--- a/docs/reference/Makefile.am
+++ b/docs/reference/Makefile.am
@@ -22,7 +22,7 @@ DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
# gtk-doc will search all .c & .h files beneath here for inline comments
# documenting the functions and macros.
# e.g. DOC_SOURCE_DIR=../../../gtk
-DOC_SOURCE_DIR=../../src/libappindicator
+DOC_SOURCE_DIR=../../src
# Extra options to pass to gtkdoc-scangobj. Not normally needed.
SCANGOBJ_OPTIONS=--nogtkinit --type-init-func="g_type_init()"
@@ -50,8 +50,8 @@ FIXXREF_OPTIONS=
# Used for dependencies. The docs will be rebuilt if any of these change.
# e.g. HFILE_GLOB=$(top_srcdir)/gtk/*.h
# e.g. CFILE_GLOB=$(top_srcdir)/gtk/*.c
-HFILE_GLOB=$(top_srcdir)/src/libappindicator/*.h
-CFILE_GLOB=$(top_srcdir)/src/libappindicator/*.c
+HFILE_GLOB=$(top_srcdir)/src/*.h
+CFILE_GLOB=$(top_srcdir)/src/*.c
# Header files to ignore when scanning.
# e.g. IGNORE_HFILES=gtkdebug.h gtkintl.h
@@ -75,7 +75,7 @@ expand_content_files=
# signals and properties.
# e.g. GTKDOC_CFLAGS=-I$(top_srcdir) -I$(top_builddir) $(GTK_DEBUG_FLAGS)
# e.g. GTKDOC_LIBS=$(top_builddir)/gtk/$(gtktargetlib)
-GTKDOC_CFLAGS=-I$(top_srcdir) -I$(top_srcdir)/src -I$(top_srcdir)/src/libappindicator $(INDICATOR_CFLAGS)
+GTKDOC_CFLAGS=-I$(top_srcdir) -I$(top_srcdir)/src -I$(top_srcdir)/src $(INDICATOR_CFLAGS)
GTKDOC_LIBS=$(top_builddir)/src/libappindicator.la $(top_builddir)/src/libapplication.la
# This includes the standard gtk-doc make rules, copied by gtkdocize.