aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-11-08 23:03:39 -0600
committerTed Gould <ted@canonical.com>2009-11-08 23:03:39 -0600
commit3d0184bcbf410c6e98bde748dad0f1137f926e57 (patch)
tree5629673a8972654e096c677919b6a26cc9f5ee84 /src/Makefile.am
parent3345ad50147621c5a3b374e50754a312db609a0f (diff)
parentd0abddaaf72e621a495871e5805cd39a51891b2b (diff)
downloadayatana-indicator-application-3d0184bcbf410c6e98bde748dad0f1137f926e57.tar.gz
ayatana-indicator-application-3d0184bcbf410c6e98bde748dad0f1137f926e57.tar.bz2
ayatana-indicator-application-3d0184bcbf410c6e98bde748dad0f1137f926e57.zip
Building the service and getting things in better shape.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 273c2dc..21d7cf8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -4,6 +4,7 @@ BUILT_SOURCES =
EXTRA_DIST =
include $(top_srcdir)/Makefile.am.enum
+include $(top_srcdir)/Makefile.am.marshal
##################################
# Indicator
@@ -33,7 +34,12 @@ indicator_custom_service_SOURCES = \
custom-service.c \
custom-service-appstore.h \
custom-service-appstore.c \
+ custom-service-marshal.h \
+ custom-service-marshal.c \
custom-service-server.h \
+ custom-service-watcher.h \
+ custom-service-watcher.c \
+ dbus-properties-client.h \
dbus-shared.h \
notification-item-client.h \
notification-watcher-server.h
@@ -43,6 +49,9 @@ indicator_custom_service_CFLAGS = \
indicator_custom_service_LDADD = \
$(INDICATOR_LIBS)
+glib_marshal_list = custom-service-marshal.list
+glib_marshal_prefix = _custom_service_marshal
+
##################################
# Library
##################################
@@ -88,6 +97,7 @@ libcustomindicator_la_LIBADD = \
DBUS_SPECS = \
custom-service.xml \
+ dbus-properties.xml \
notification-item.xml \
notification-watcher.xml