aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-16 12:20:43 -0500
committerTed Gould <ted@canonical.com>2009-10-16 12:20:43 -0500
commit664bc74b6f0b3eb6ca30539628e2350ed3a2e20c (patch)
treec04625cef42f15f8b66cac9855596c8577d33dd4 /src/Makefile.am
parente265e46176c6c8633849b3a5d65b7f86bda47318 (diff)
parentafd1d1747e91db94c370ea4a3400906fe4227e09 (diff)
downloadayatana-indicator-application-664bc74b6f0b3eb6ca30539628e2350ed3a2e20c.tar.gz
ayatana-indicator-application-664bc74b6f0b3eb6ca30539628e2350ed3a2e20c.tar.bz2
ayatana-indicator-application-664bc74b6f0b3eb6ca30539628e2350ed3a2e20c.zip
Adding in the DBus interface files and building of those.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am38
1 files changed, 35 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 63f0c64..2139b62 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,4 @@
-libexec_PROGRAMS = indicator-custom-service
-
##################################
# Indicator
##################################
@@ -22,10 +20,44 @@ libcustom_la_LDFLAGS = -module -avoid-version
# Service
##################################
+libexec_PROGRAMS = indicator-custom-service
+
indicator_custom_service_SOURCES = \
- custom-service.c
+ custom-service.c \
+ notification-item-client.h \
+ notification-watcher-server.h
indicator_custom_service_CFLAGS = \
$(INDICATOR_CFLAGS) \
-Wall -Werror
indicator_custom_service_LDADD = \
$(INDICATOR_LIBS)
+
+##################################
+# DBus Specs
+##################################
+
+DBUS_SPECS = \
+ notification-item.xml \
+ notification-watcher.xml
+
+%-client.h: %.xml
+ dbus-binding-tool \
+ --prefix=_$(subst -,_,$(<:.xml=))_client \
+ --mode=glib-client \
+ --output=$@ \
+ $<
+
+%-server.h: %.xml
+ dbus-binding-tool \
+ --prefix=_$(subst -,_,$(<:.xml=))_server \
+ --mode=glib-server \
+ --output=$@ \
+ $<
+
+BUILT_SOURCES = \
+ $(DBUS_SPECS:.xml=-client.h) \
+ $(DBUS_SPECS:.xml=-server.h)
+
+CLEANFILES = $(BUILT_SOURCES)
+
+EXTRA_DIST = $(DBUS_SPECS)