aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-08-13 12:22:42 -0500
committerTed Gould <ted@gould.cx>2010-08-13 12:22:42 -0500
commit564b2afe7960f5b277070c00370cbf1358e5246f (patch)
tree6711d5bfabf1b02f08f169a61dd1c34a2f2d6260 /src/Makefile.am
parent7a4bfc9135ea55b0f495513fbd7ad2734b328098 (diff)
parentd81670cc9cf081b1296561d9da2176975da7643b (diff)
downloadayatana-indicator-application-564b2afe7960f5b277070c00370cbf1358e5246f.tar.gz
ayatana-indicator-application-564b2afe7960f5b277070c00370cbf1358e5246f.tar.bz2
ayatana-indicator-application-564b2afe7960f5b277070c00370cbf1358e5246f.zip
Updating to trunk
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0e84749..1c4e7ae 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -44,17 +44,20 @@ indicator_application_service_SOURCES = \
application-service.c \
application-service-appstore.h \
application-service-appstore.c \
- application-service-lru-file.h \
- application-service-lru-file.c \
application-service-marshal.c \
application-service-watcher.h \
application-service-watcher.c \
app-indicator-enum-types.c \
- dbus-shared.h
+ dbus-shared.h \
+ generate-id.h \
+ generate-id.c
+
indicator_application_service_CFLAGS = \
$(INDICATOR_CFLAGS) \
+ -DDATADIR="\"$(pkgdatadir)\"" \
-Wall -Werror \
-DG_LOG_DOMAIN=\"indicator-application-service\"
+
indicator_application_service_LDADD = \
$(INDICATOR_LIBS) \
libappindicator.la
@@ -95,7 +98,9 @@ libappindicator_la_SOURCES = \
$(libappindicator_headers) \
app-indicator-enum-types.c \
app-indicator.c \
- application-service-marshal.c
+ application-service-marshal.c \
+ generate-id.h \
+ generate-id.c
libappindicator_la_LDFLAGS = \
-version-info 1:0:0 \