aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-08-12 09:30:07 -0500
committerTed Gould <ted@gould.cx>2010-08-12 09:30:07 -0500
commitf6b5ccdf34323425d94e594c6f748c1d4201cf89 (patch)
tree12edca8958f0b5ac704f5724ac75a7263660498f /src/Makefile.am
parentd7c7a2ae1656af559bfbdb2716fe381d313b5a53 (diff)
parentb7d28a11de1b283cffa4caea1abfb94e01db3fdd (diff)
downloadayatana-indicator-application-f6b5ccdf34323425d94e594c6f748c1d4201cf89.tar.gz
ayatana-indicator-application-f6b5ccdf34323425d94e594c6f748c1d4201cf89.tar.bz2
ayatana-indicator-application-f6b5ccdf34323425d94e594c6f748c1d4201cf89.zip
Switching to using ordering IDs instead of the LRU file.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0e84749..1c4e7ae 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -44,17 +44,20 @@ indicator_application_service_SOURCES = \
application-service.c \
application-service-appstore.h \
application-service-appstore.c \
- application-service-lru-file.h \
- application-service-lru-file.c \
application-service-marshal.c \
application-service-watcher.h \
application-service-watcher.c \
app-indicator-enum-types.c \
- dbus-shared.h
+ dbus-shared.h \
+ generate-id.h \
+ generate-id.c
+
indicator_application_service_CFLAGS = \
$(INDICATOR_CFLAGS) \
+ -DDATADIR="\"$(pkgdatadir)\"" \
-Wall -Werror \
-DG_LOG_DOMAIN=\"indicator-application-service\"
+
indicator_application_service_LDADD = \
$(INDICATOR_LIBS) \
libappindicator.la
@@ -95,7 +98,9 @@ libappindicator_la_SOURCES = \
$(libappindicator_headers) \
app-indicator-enum-types.c \
app-indicator.c \
- application-service-marshal.c
+ application-service-marshal.c \
+ generate-id.h \
+ generate-id.c
libappindicator_la_LDFLAGS = \
-version-info 1:0:0 \