aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSense Hofstede <qense@ubuntu.com>2010-05-23 12:44:53 +0200
committerSense Hofstede <qense@ubuntu.com>2010-05-23 12:44:53 +0200
commit01fafa492912486a291d70d2289ba4d77355be92 (patch)
tree9cdb2d6ca4fde8ae30cdef17c96cb3e2f23d3695 /src/Makefile.am
parente09b4591cf46334934a233511b18d7706802bd35 (diff)
downloadayatana-indicator-application-01fafa492912486a291d70d2289ba4d77355be92.tar.gz
ayatana-indicator-application-01fafa492912486a291d70d2289ba4d77355be92.tar.bz2
ayatana-indicator-application-01fafa492912486a291d70d2289ba4d77355be92.zip
Documentation and introspection fixes and such
* Several documentation and introspection fixes * Some small fixes to the mono bindings
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 3 insertions, 12 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c2bac63..a5c47e7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -52,7 +52,8 @@ indicator_application_service_CFLAGS = \
-Wall -Werror \
-DG_LOG_DOMAIN=\"indicator-application-service\"
indicator_application_service_LDADD = \
- $(INDICATOR_LIBS)
+ $(INDICATOR_LIBS) \
+ libappindicator.la
glib_marshal_list = application-service-marshal.list
glib_marshal_prefix = _application_service_marshal
@@ -65,19 +66,9 @@ pkgconfig_DATA = appindicator-0.1.pc
pkgconfigdir = $(libdir)/pkgconfig
glib_enum_h = app-indicator-enum-types.h
-glib_enum_c = app-indicator-enum-types.gen.c
+glib_enum_c = app-indicator-enum-types.c
glib_enum_headers = $(libappindicator_headers)
-app-indicator-enum-types.c: app-indicator-enum-types.gen.c
- sed -e "s|\"passive\"|\"Passive\"|" \
- -e "s|\"active\"|\"Active\"|" \
- -e "s|\"attention\"|\"NeedsAttention\"|" \
- -e "s|\"application-status\"|\"ApplicationStatus\"|" \
- -e "s|\"communications\"|\"Communications\"|" \
- -e "s|\"system-services\"|\"SystemServices\"|" \
- -e "s|\"hardware\"|\"Hardware\"|" \
- -e "s|\"other\"|\"Other\"|" \
- $< > $@
DISTCLEANFILES += app-indicator-enum-types.c
lib_LTLIBRARIES = \