aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2009-12-16 14:29:18 -0500
committerKen VanDine <ken.vandine@canonical.com>2009-12-16 14:29:18 -0500
commit251da6dc9c3ce7e84e83d734bb08cc42c6db2480 (patch)
tree7fa3673e18ea34306adaf6367c1aa5c0aee6d35e /src/Makefile.am
parentc66e720d0d59050fecb263cc2f7daa7c2ac88f09 (diff)
downloadayatana-indicator-application-251da6dc9c3ce7e84e83d734bb08cc42c6db2480.tar.gz
ayatana-indicator-application-251da6dc9c3ce7e84e83d734bb08cc42c6db2480.tar.bz2
ayatana-indicator-application-251da6dc9c3ce7e84e83d734bb08cc42c6db2480.zip
exclude the path in subst replace in the dbus-binding-tool command
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ee4b7a7..f101d12 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -107,14 +107,14 @@ DBUS_SPECS = \
%-client.h: %.xml
dbus-binding-tool \
- --prefix=_$(subst -,_,$(<:.xml=))_client \
+ --prefix=_$(notdir $(subst -,_,$(<:.xml=)))_client \
--mode=glib-client \
--output=$@ \
$<
%-server.h: %.xml
dbus-binding-tool \
- --prefix=_$(subst -,_,$(<:.xml=))_server \
+ --prefix=_$(notdir $(subst -,_,$(<:.xml=)))_server \
--mode=glib-server \
--output=$@ \
$<