aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-12-02 16:49:42 -0600
committerTed Gould <ted@gould.cx>2010-12-02 16:49:42 -0600
commit6e2c63951469dff55d6e6236f61bed7c44413459 (patch)
tree7f92d68314959da0c938a988a3db06dde0c139c0 /src/Makefile.am
parent7c3589d667e07d776b8a470bf52a68868aaec182 (diff)
downloadayatana-indicator-application-6e2c63951469dff55d6e6236f61bed7c44413459.tar.gz
ayatana-indicator-application-6e2c63951469dff55d6e6236f61bed7c44413459.tar.bz2
ayatana-indicator-application-6e2c63951469dff55d6e6236f61bed7c44413459.zip
Linking to the install directory of libappindicator for the header files
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 27ddc10..e461599 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -54,20 +54,20 @@ indicator_application_service_SOURCES = \
indicator_application_service_CFLAGS = \
$(INDICATOR_CFLAGS) \
+ -I$(APP_INDICATOR_INCLUDE) \
-DDATADIR="\"$(pkgdatadir)\"" \
-Wall -Werror \
-DG_LOG_DOMAIN=\"indicator-application-service\"
indicator_application_service_LDADD = \
- $(INDICATOR_LIBS) \
- libappindicator.la
+ $(INDICATOR_LIBS)
glib_marshal_list = application-service-marshal.list
glib_marshal_prefix = _application_service_marshal
glib_enum_h = app-indicator-enum-types.h
glib_enum_c = app-indicator-enum-types.c
-glib_enum_headers = $(addprefix $(srcdir)/, $(libappindicator_headers))
+glib_enum_headers = $(wildcard $(APP_INDICATOR_INCLUDE)/libappindicator/*.h)
DISTCLEANFILES += app-indicator-enum-types.c