aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-05-20 17:32:25 -0500
committerTed Gould <ted@gould.cx>2010-05-20 17:32:25 -0500
commit6efcf99c34c7a3d6025aaa116f8ca95df6618f87 (patch)
treee77fd40d9d7b51998be7be05b18c4db019ea88bf /src/Makefile.am
parent9366eb01ebca988dc646683e1091f10240009a99 (diff)
downloadayatana-indicator-application-6efcf99c34c7a3d6025aaa116f8ca95df6618f87.tar.gz
ayatana-indicator-application-6efcf99c34c7a3d6025aaa116f8ca95df6618f87.tar.bz2
ayatana-indicator-application-6efcf99c34c7a3d6025aaa116f8ca95df6618f87.zip
Fixing which sources are marked as BUILT
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 14 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c96bbed..19ce66d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -32,21 +32,24 @@ libapplication_la_LDFLAGS = -module -avoid-version
libexec_PROGRAMS = indicator-application-service
+BUILT_SOURCES += \
+ application-service-server.h \
+ application-service-marshal.h \
+ application-service-marshal.c \
+ dbus-properties-client.h \
+ notification-item-client.h \
+ notification-watcher-server.h
+
indicator_application_service_SOURCES = \
application-service.c \
application-service-appstore.h \
application-service-appstore.c \
application-service-lru-file.h \
application-service-lru-file.c \
- application-service-marshal.h \
application-service-marshal.c \
- application-service-server.h \
application-service-watcher.h \
application-service-watcher.c \
- dbus-properties-client.h \
- dbus-shared.h \
- notification-item-client.h \
- notification-watcher-server.h
+ dbus-shared.h
indicator_application_service_CFLAGS = \
$(INDICATOR_CFLAGS) \
-Wall -Werror \
@@ -92,11 +95,13 @@ libappindicatorinclude_HEADERS = \
$(libappindicator_headers) \
$(glib_enum_h)
+BUILT_SOURCES += \
+ notification-watcher-client.h \
+ notification-item-server.h
+
libappindicator_la_SOURCES = \
$(libappindicator_headers) \
app-indicator-enum-types.c \
- notification-watcher-client.h \
- notification-item-server.h \
app-indicator.c
libappindicator_la_LDFLAGS = \
@@ -117,6 +122,7 @@ libappindicator_la_LIBADD = \
##################################
DBUS_SPECS = \
+ dbus-properties.xml \
application-service.xml \
notification-item.xml \
notification-watcher.xml