aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNeil Jagdish Patel <neil.patel@canonical.com>2010-04-13 12:59:51 +0100
committerNeil Jagdish Patel <neil.patel@canonical.com>2010-04-13 12:59:51 +0100
commit7210a540b4ad0936773a952bef297f9cf5af98bb (patch)
tree3d1de26b1c527aa6cd7de2c65a77712913fcaba5 /src/Makefile.am
parentff63763f4f00d1c33a6557f3ea90dc26f7bc3c10 (diff)
downloadayatana-indicator-application-7210a540b4ad0936773a952bef297f9cf5af98bb.tar.gz
ayatana-indicator-application-7210a540b4ad0936773a952bef297f9cf5af98bb.tar.bz2
ayatana-indicator-application-7210a540b4ad0936773a952bef297f9cf5af98bb.zip
Add G_LOG_DOMAIN support to the various targets for better messages
modified: src/Makefile.am
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index efae713..9f2771e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,6 @@
-CLEANFILES =
-DISTCLEANFILES =
-BUILT_SOURCES =
+CLEANFILES =
+DISTCLEANFILES =
+BUILT_SOURCES =
EXTRA_DIST = libappindicator/appindicator-0.1.pc.in
include $(top_srcdir)/Makefile.am.enum
@@ -21,7 +21,8 @@ libapplication_la_CFLAGS = $(INDICATOR_CFLAGS) \
-Wl,-Bsymbolic-functions \
-Wl,-z,defs \
-Wl,--as-needed \
- -Werror
+ -Werror \
+ -DG_LOG_DOMAIN=\"Indicator-Application\"
libapplication_la_LIBADD = $(INDICATOR_LIBS)
libapplication_la_LDFLAGS = -module -avoid-version
@@ -48,7 +49,8 @@ indicator_application_service_SOURCES = \
notification-watcher-server.h
indicator_application_service_CFLAGS = \
$(INDICATOR_CFLAGS) \
- -Wall -Werror
+ -Wall -Werror \
+ -DG_LOG_DOMAIN=\"indicator-application-service\"
indicator_application_service_LDADD = \
$(INDICATOR_LIBS)
@@ -104,7 +106,8 @@ libappindicator_la_LDFLAGS = \
libappindicator_la_CFLAGS = \
$(INDICATOR_CFLAGS) \
- -Wall -Werror
+ -Wall -Werror \
+ -DG_LOG_DOMAIN=\"libappindicator\"
libappindicator_la_LIBADD = \
$(INDICATOR_LIBS)