aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-13 22:16:49 -0500
committerTed Gould <ted@canonical.com>2009-10-13 22:16:49 -0500
commit7b2c29fbd83d2679a123a8825c92b3ac97e79229 (patch)
treed3b2b450936ebdf71ed8822072d7900c25e651a6 /src/Makefile.am
parent9fc5dd8c5047e7d04872d223c5ec0124e3aa8946 (diff)
downloadayatana-indicator-application-7b2c29fbd83d2679a123a8825c92b3ac97e79229.tar.gz
ayatana-indicator-application-7b2c29fbd83d2679a123a8825c92b3ac97e79229.tar.bz2
ayatana-indicator-application-7b2c29fbd83d2679a123a8825c92b3ac97e79229.zip
Getting to building all these header files nicely.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am36
1 files changed, 33 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 63f0c64..ae83eb3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,4 @@
-libexec_PROGRAMS = indicator-custom-service
-
##################################
# Indicator
##################################
@@ -22,10 +20,42 @@ libcustom_la_LDFLAGS = -module -avoid-version
# Service
##################################
+libexec_PROGRAMS = indicator-custom-service
+
indicator_custom_service_SOURCES = \
- custom-service.c
+ custom-service.c \
+ notification-item-client.h \
+ notification-watcher-server.h
indicator_custom_service_CFLAGS = \
$(INDICATOR_CFLAGS) \
-Wall -Werror
indicator_custom_service_LDADD = \
$(INDICATOR_LIBS)
+
+##################################
+# DBus Specs
+##################################
+
+DBUS_SPECS = \
+ notification-item.xml \
+ notification-watcher.xml
+
+%-client.h: %.xml
+ dbus-binding-tool \
+ --prefix=_$(<:.xml=)_client \
+ --mode=glib-client \
+ --output=$@ \
+ $<
+
+%-server.h: %.xml
+ dbus-binding-tool \
+ --prefix=_$(<:.xml=)_server \
+ --mode=glib-server \
+ --output=$@ \
+ $<
+
+BUILT_SOURCES = \
+ $(DBUS_SPECS:.xml=-client.h) \
+ $(DBUS_SPECS:.xml=-server.h)
+
+DIST_CLEAN = $(BUILT_SOURCES)