aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-15 21:12:52 -0500
committerTed Gould <ted@canonical.com>2009-10-15 21:12:52 -0500
commitb666cc1867e04d697f381fa8033803b9e7d0f61d (patch)
treeeaee5c113496b2cbdfd59076a20de74dc9b10cbd /src/Makefile.am
parentbe305bc2babcc1200930aa60e7d14554e8fba214 (diff)
downloadayatana-indicator-application-b666cc1867e04d697f381fa8033803b9e7d0f61d.tar.gz
ayatana-indicator-application-b666cc1867e04d697f381fa8033803b9e7d0f61d.tar.bz2
ayatana-indicator-application-b666cc1867e04d697f381fa8033803b9e7d0f61d.zip
Building a basic library starting out.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2139b62..bcaba37 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -33,6 +33,39 @@ indicator_custom_service_LDADD = \
$(INDICATOR_LIBS)
##################################
+# Library
+##################################
+
+lib_LTLIBRARIES = \
+ libcustomindicator.la
+
+libcustomindicatorincludedir=$(includedir)/libcustomindicator-0.1/libcustomindicator
+
+libcustomindicator_headers = \
+ libcustomindicator/custom-indicator.h
+
+libcustomindicatorinclude_HEADERS = \
+ $(libcustomindicator_headers)
+
+libcustomindicator_la_SOURCES = \
+ $(libcustomindicator_headers) \
+ notification-watcher-client.h \
+ notification-item-server.h \
+ libcustomindicator/custom-indicator.c
+
+libcustomindicator_la_LDFLAGS = \
+ -version-info 0:0:0 \
+ -no-undefined \
+ -export-symbols-regex "^[^_d].*"
+
+libcustomindicator_la_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror
+
+libcustomindicator_la_LIBADD = \
+ $(INDICATOR_LIBS)
+
+##################################
# DBus Specs
##################################