aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-06-01 10:58:57 -0500
committerTed Gould <ted@gould.cx>2010-06-01 10:58:57 -0500
commite0ddc2dbf98ad7411b9a29b34bfd99f94f1ce74e (patch)
tree7d385aef35dea7ba3fab4798b9c008eede3732f2 /src/Makefile.am
parentf7fd52b7477bfbef0762e8e608f3a9b095133fd1 (diff)
parent01fafa492912486a291d70d2289ba4d77355be92 (diff)
downloadayatana-indicator-application-e0ddc2dbf98ad7411b9a29b34bfd99f94f1ce74e.tar.gz
ayatana-indicator-application-e0ddc2dbf98ad7411b9a29b34bfd99f94f1ce74e.tar.bz2
ayatana-indicator-application-e0ddc2dbf98ad7411b9a29b34bfd99f94f1ce74e.zip
Fixes to docuementation and making the enums build correctly with gtk-mkenum
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am20
1 files changed, 6 insertions, 14 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 28cd4c3..8662179 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -43,6 +43,7 @@ indicator_application_service_SOURCES = \
application-service-server.h \
application-service-watcher.h \
application-service-watcher.c \
+ app-indicator-enum-types.c \
dbus-properties-client.h \
dbus-shared.h \
notification-item-client.h \
@@ -52,7 +53,8 @@ indicator_application_service_CFLAGS = \
-Wall -Werror \
-DG_LOG_DOMAIN=\"indicator-application-service\"
indicator_application_service_LDADD = \
- $(INDICATOR_LIBS)
+ $(INDICATOR_LIBS) \
+ libappindicator.la
glib_marshal_list = application-service-marshal.list
glib_marshal_prefix = _application_service_marshal
@@ -65,19 +67,9 @@ pkgconfig_DATA = appindicator-0.1.pc
pkgconfigdir = $(libdir)/pkgconfig
glib_enum_h = app-indicator-enum-types.h
-glib_enum_c = app-indicator-enum-types.gen.c
-glib_enum_headers = $(libappindicator_headers)
-
-app-indicator-enum-types.c: app-indicator-enum-types.gen.c
- sed -e "s|\"passive\"|\"Passive\"|" \
- -e "s|\"active\"|\"Active\"|" \
- -e "s|\"attention\"|\"NeedsAttention\"|" \
- -e "s|\"application-status\"|\"ApplicationStatus\"|" \
- -e "s|\"communications\"|\"Communications\"|" \
- -e "s|\"system-services\"|\"SystemServices\"|" \
- -e "s|\"hardware\"|\"Hardware\"|" \
- -e "s|\"other\"|\"Other\"|" \
- $< > $@
+glib_enum_c = app-indicator-enum-types.c
+glib_enum_headers = $(addprefix $(srcdir)/, $(libappindicator_headers))
+
DISTCLEANFILES += app-indicator-enum-types.c
lib_LTLIBRARIES = \