aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-13 15:37:08 -0500
committerTed Gould <ted@canonical.com>2009-10-13 15:37:08 -0500
commitfb328a435358e26c1f2779e2bf07ddb05b60e93e (patch)
tree3d3f461747a9626556cc6b2e11d280f7f1fa3c77 /src/Makefile.am
parentd7640ed6bcf9eaa042e2947fe3c32791b71d3f95 (diff)
downloadayatana-indicator-application-fb328a435358e26c1f2779e2bf07ddb05b60e93e.tar.gz
ayatana-indicator-application-fb328a435358e26c1f2779e2bf07ddb05b60e93e.tar.bz2
ayatana-indicator-application-fb328a435358e26c1f2779e2bf07ddb05b60e93e.zip
Building a basic indicator and the service to go along with it.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am32
1 files changed, 31 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 599c41b..63f0c64 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1 +1,31 @@
-# Data
+
+libexec_PROGRAMS = indicator-custom-service
+
+##################################
+# Indicator
+##################################
+
+customlibdir = $(INDICATORDIR)
+customlib_LTLIBRARIES = libcustom.la
+libcustom_la_SOURCES = \
+ indicator-custom.c
+libcustom_la_CFLAGS = $(INDICATOR_CFLAGS) \
+ -Wall \
+ -Wl,-Bsymbolic-functions \
+ -Wl,-z,defs \
+ -Wl,--as-needed \
+ -Werror
+libcustom_la_LIBADD = $(INDICATOR_LIBS)
+libcustom_la_LDFLAGS = -module -avoid-version
+
+##################################
+# Service
+##################################
+
+indicator_custom_service_SOURCES = \
+ custom-service.c
+indicator_custom_service_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror
+indicator_custom_service_LDADD = \
+ $(INDICATOR_LIBS)