aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-12-02 11:57:06 -0600
committerTed Gould <ted@gould.cx>2009-12-02 11:57:06 -0600
commit29ef598378429811715f727295f40bbcdb3fa092 (patch)
tree6b40b05a5679d50b2128d80bea770cd8f91fa3a5 /src/Makefile.am
parent71797b37811381cfb48e711348a1259f02bdd125 (diff)
parent69448c00ed4dec738e32cc78f916a110fcd6d3a7 (diff)
downloadayatana-indicator-application-29ef598378429811715f727295f40bbcdb3fa092.tar.gz
ayatana-indicator-application-29ef598378429811715f727295f40bbcdb3fa092.tar.bz2
ayatana-indicator-application-29ef598378429811715f727295f40bbcdb3fa092.zip
Implementing the service and having the indicator and app
library start using it.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ff5b26e..102804e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -4,6 +4,7 @@ BUILT_SOURCES =
EXTRA_DIST =
include $(top_srcdir)/Makefile.am.enum
+include $(top_srcdir)/Makefile.am.marshal
##################################
# Indicator
@@ -12,6 +13,8 @@ include $(top_srcdir)/Makefile.am.enum
customlibdir = $(INDICATORDIR)
customlib_LTLIBRARIES = libcustom.la
libcustom_la_SOURCES = \
+ custom-service-marshal.c \
+ dbus-shared.h \
indicator-custom.c
libcustom_la_CFLAGS = $(INDICATOR_CFLAGS) \
-Wall \
@@ -30,6 +33,15 @@ libexec_PROGRAMS = indicator-custom-service
indicator_custom_service_SOURCES = \
custom-service.c \
+ custom-service-appstore.h \
+ custom-service-appstore.c \
+ custom-service-marshal.h \
+ custom-service-marshal.c \
+ custom-service-server.h \
+ custom-service-watcher.h \
+ custom-service-watcher.c \
+ dbus-properties-client.h \
+ dbus-shared.h \
notification-item-client.h \
notification-watcher-server.h
indicator_custom_service_CFLAGS = \
@@ -38,6 +50,9 @@ indicator_custom_service_CFLAGS = \
indicator_custom_service_LDADD = \
$(INDICATOR_LIBS)
+glib_marshal_list = custom-service-marshal.list
+glib_marshal_prefix = _custom_service_marshal
+
##################################
# Library
##################################
@@ -82,6 +97,8 @@ libcustomindicator_la_LIBADD = \
##################################
DBUS_SPECS = \
+ custom-service.xml \
+ dbus-properties.xml \
notification-item.xml \
notification-watcher.xml